AUE(4) BSD Programmer's Manual AUE(4)
aue - ADMtek AN986 / ADM8511 Pegasus family USB Ethernet driver
aue* at uhub? port ? ukphy* at mii?
The aue driver provides support for USB Ethernet adapters based on the ADMtek AN986 ("Pegasus") and ADM8511 ("Pegasus II") chipsets. This in- cludes the following adapters: 3Com 3c460b Abocom UFE1000 Abocom DSB650TX Accton USB320-EC Accton SpeedStream Ethernet Admtek Pegasus Admtek Pegasus II Belkin USB to LAN Billionton Systems USB100 Billionton Systems USB100EL Billionton Systems USB100LP Billionton Systems USBE100 Corega FEther USB-TX Corega FEther USB-TXS D-Link DSB-650 D-Link DSB-650TX D-Link DSB-650TX-PNA Elecom LD-USB/TX Elecom LD-USBL/TX Elsa Microlink USB2Ethernet I/O DATA USB ETTX Kingston KNU101TX LinkSys USB100TX LinkSys USB100H1 LinkSys USB10T LinkSys USB10TA LinkSys USB10TX Melco Inc. LUA-TX Melco Inc. LUA2-TX Netgear FA101 Siemens SpeedStream USB Smartbridges smartNIC 2 SMC 2202USB SMC EZ Connect USB SOHOware NUB100 The Pegasus family of chipsets contain a 10/100 Ethernet MAC with an MII interface and are designed to work with both Ethernet and HomePNA tran- sceivers. Although the chipsets are designed to interface with 100Mbps peripherals, the USB 1.x standards specify a maximum transfer speed of 12Mbps. Users should therefore not expect to actually achieve 100Mbps speeds with these devices. The Pegasus chipsets support a 64-bit multicast hash table, single per- fect filter entry for the station address and promiscuous mode. Packets are received and transmitted over separate USB bulk transfer endpoints. The aue driver supports the following media types: autoselect Enable autoselection of the media type and options. The user can manually override the autoselected mode by adding media options to the appropriate hostname.if(5) file. 10baseT Set 10Mbps operation. The mediaopt option can also be used to enable full-duplex operation. Not specifying full duplex im- plies half-duplex mode. 100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option can also be used to enable full-duplex operation. Not speci- fying full duplex implies half-duplex mode. The aue driver supports the following media options: full-duplex Force full duplex operation. The interface will operate in half duplex mode if this media option is not specified. For more information on configuring this device, see ifconfig(8).
aue%d: watchdog timeout A packet was queued for transmission and a transmit command was issued, however the device failed to acknowledge the transmission before a timeout expired. aue%d: no memory for rx list The driver failed to allocate an mbuf for the receiver ring.
arp(4), ifmedia(4), intro(4), netintro(4), usb(4), hostname.if(5), ifconfig(8) ADMtek AN986 and ADM8511 data sheets, http://www.admtek.com.tw.
The aue device driver first appeared in FreeBSD 4.0. OpenBSD support was added in OpenBSD 2.7.
The aue driver was written by Bill Paul <firstname.lastname@example.org> and port- ed to OpenBSD by Aaron Campbell <email@example.com>. MirOS BSD #10-current December 25, 1999 1
Generated on 2014-02-10 02:47:05 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.