WSMOUSED(8) BSD System Manager's Manual (i386) WSMOUSED(8)
wsmoused - wsmouse daemon
wsmoused [-2df] [-C thresh] [-I file] [-M N=M] [-p device] [-t type] wsmoused -i [-p device]
wsmoused listens for mouse events on the specified device and communi- cates them to the wscons(4) driver through the /dev/ttyCcfg interface. Its purpose is to provide copy/paste functionality on the PC console. By default, the left mouse button is used to select text (in the familiar click-and-drag fashion), the right button is used to extend the selec- tion, and the middle button pastes. This behavior can be modified through the use of -M, i.e., -M 2=3 maps the right mouse button to paste. The options are as follows: -2 Indicate that the mouse has two-buttons. In that case, the right button pastes. -C thresh Set double click speed as the maximum interval in msec between button clicks. If omitted, the default value of 500 msec will be assumed. This option will have effect only on the cut and paste operations in the text mode console. -d Enable debugging messages. -f Do not become a daemon and instead run as a foreground pro- cess. Useful for testing and debugging. -I file Write the process ID of wsmoused to the specified file. If om- itted, the process ID will be stored in /var/run/wsmoused.pid. -i Print the type and the protocol of the mouse and exit. -M N=M Assign the physical button M to the logical button N. You may specify as many instances of this option as you like. More than one physical button may be assigned to a logical button at the same time. In this case the logical button will be down, if either of the assigned physical buttons is held down. Do not put space around '='. -p device Use device device to communicate with the mouse. If this op- tion is not present, the device opened is /dev/wsmouse (the multiplexer device that receives all mouse events from all wsmouse compatible mice on the system). For a serial mouse, you have to explicitly specify the serial port, i.e. device must be one of /dev/cua0[0-3]. -t type This option only applies to serial mice. It specifies the pro- tocol used by the serial mice. You may explicitly specify a type listed below or use auto to let wsmoused automatically select an appropriate protocol for the given mouse, if the serial mouse respects the PnP COM specification. If this option is not specified, auto is assumed. Under normal circumstances, you need to use this option only if the mouse is not PnP compatible. Valid protocol types for this option are the following: microsoft Microsoft serial mouse protocol. Most 2-button serial mice use this protocol. intellimouse Microsoft IntelliMouse protocol. Genius Net- Mouse, ASCII Mie Mouse, Logitech MouseMan+, and FirstMouse+ use this protocol as well. Other mice with a roller/wheel may be compatible with this protocol. mousesystems MouseSystems 5-byte protocol. 3-button mice may use this protocol. mmseries MM Series mouse protocol. logitech Logitech mouse protocol. Note that this is for old Logitech models. mouseman or intellimouse should be specified for newer models. mouseman Logitech MouseMan and TrackMan protocol. Some 3-button mice may be compatible with this pro- tocol. Note that MouseMan+ and FirstMouse+ use intellimouse protocol rather than this one. glidepoint ALPS GlidePoint protocol. thinkingmouse Kensington ThinkingMouse protocol. mmhitab Hitachi tablet protocol. wsmoused will happily coexist with the X Window System, provided that the mouse device is supported by wsmouse(4). Serial mice do not have a wsmouse(4) compatible driver, so wsmoused has to be killed before start- ing the X Window System.
The wsmoused daemon is a slightly modified version of the moused daemon from the FreeBSD project, written by Michael Smith <msmith@FreeBSD.org>. Both inherit code from the XFree Pro- ject. MirOS BSD #10-current April 8, 2001 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.