VIPW(8) BSD System Manager's Manual VIPW(8)
vipw - edit the password file
vipw edits the password file after setting the appropriate locks, and does any necessary processing after the password file is unlocked. If the password file is already locked for editing by another user, vipw will ask you to try again later. The default editor for vipw is vi(1). vipw performs a number of consistency checks on the password entries, and will not allow a password file with a "mangled" entry to be installed. If vipw rejects the new password file, the user is prompted to re-enter the edit session. Once the information has been verified, vipw uses pwd_mkdb(8) to update the user database. This is run in the background, and, at very large sites could take several minutes. Until this update is completed, the password file is unavailable for other updates and the new information is not available to programs. Which type of cipher is used to encrypt the password information depends on the configuration in login.conf(5).
If the following environment variable exists it will be utilized by vipw: EDITOR The editor specified by the string EDITOR will be invoked instead of the default editor vi(1).
chpass(1), passwd(1), login.conf(5), passwd(5), adduser(8), pwd_mkdb(8)
The vipw command appeared in 4.0BSD. MirOS BSD #10-current June 6, 1993 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.