SPAMD-SETUP(8) BSD System Manager's Manual SPAMD-SETUP(8)
spamd-setup - parse and load file of spammer addresses
The spamd-setup utility sends blacklist data to spamd(8), as well as con- figuring mail rejection messages for blacklist entries. When spamd-setup is run in blacklist only mode, instead of sending black- list data directly to spamd(8), it sends it to the pf(4) table <spamd>. The <spamd> table must then be used in conjunction with a pf(4) redirec- tion rule to selectively redirect mail connections to spamd(8). The options are as follows: -b Blacklisting only mode. Blacklist data is normally stored only in spamd(8). With this flag, data is stored in both spamd(8) and pf(4). Use this flag if spamd(8) is running with the -b flag too. -d Debug mode reports a few pieces of information. -n Dry-run mode. No data is shipped. Lists are specified in the configuration file /etc/mail/spamd.conf and are processed in the order specified in the all tag. Output is con- catenated and sent to a running spamd(8). Addresses are sent along with the message spamd will give on mail rejection when a matching client con- nects. The configuration port for spamd(8) is found from services(5), by looking for the named service spamd-cfg. spamd-setup reads all configuration information from the spamd.conf(5) file.
pf.conf(5), services(5), spamd.conf(5), spamd(8)
Blacklists removed from /etc/mail/spamd.conf are not automatically re- moved from the running spamd(8). If an entry is removed from /etc/mail/spamd.conf that is currently in use, it is necessary to restart spamd(8). This applies only to blacklists that are removed entirely, not those that are simply modified. MirOS BSD #10-current February 14, 2003 1
Generated on 2014-02-10 02:47:05 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.