SAVECORE(8) BSD System Manager's Manual SAVECORE(8)
savecore - save a core dump of the operating system
savecore -c savecore [-fvz] [-N system] directory
savecore copies the currently running kernel and its associated core dump into directory, and enters a reboot message and information about the core dump into the system log. The options are as follows: -c Clears the dump, so that future invocations of savecore will ig- nore it. -f Forces a dump to be taken even if the dump doesn't appear correct or there is insufficient disk space. -N system Use system as the kernel instead of the default /bsd. -v Prints out some additional debugging information. -z Compresses the core dump and kernel (see compress(1)). savecore checks the core dump in various ways to make sure that it is current and that it corresponds to the currently running system. If it passes these checks, it saves the core image in directory/bsd.#.core and the system in directory/bsd.# (or in directory/bsd.#.core.Z and directory/bsd.#.Z, respectively, if the -z option is used). The "#" is the number from the first line of the file directory/bounds, and it is incremented and stored back into the file each time savecore successfully runs. savecore also checks the available disk space before attempting to make the copies. If there is insufficient disk space in the filesystem con- taining directory, or if the file directory/minfree exists and the number of free kilobytes (for non-superusers) in the filesystem after the copies were made would be less than the number in the first line of this file, the copies are not attempted. If savecore successfully copies the kernel and the core dump, the core dump is cleared so that future invocations of savecore will ignore it. savecore is meant to be called near the end of the initialization file /etc/rc (see rc(8)).
/bsd current kernel
The savecore command appeared in 4.1BSD. Since MirOS #9, savecore can handle kernels compressed with gzip(1), too. This is, however, very slow.
The minfree code does not consider the effect of compression. MirOS BSD #10-current June 5, 1993 1
Generated on 2016-02-08 23:56:27 by $MirOS: src/scripts/roff2htm,v 1.82 2016/01/02 20:05:08 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2016 The MirOS Project, Germany.
This product includes material provided by mirabilos.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.