RTQUERY(8) BSD System Manager's Manual RTQUERY(8)
rtquery - query routing daemons for their routing tables
rtquery [-1np] [-r addr] [-t op] [-w timeout] host ...
rtquery is used to query a RIPv1/2 network routing daemon for its routing table by sending a request command. The routing information in any rout- ing response packets returned is displayed numerically and symbolically. rtquery is also used to turn tracing on or off. See routed(8) for more information about a RIPv1/2 capable routing dae- mon. The options are as follows: -1 Query using RIP version 1 instead of RIP version 2. -n Normally network and host numbers are displayed both symbolically and numerically. The -n option displays only the numeric network and host numbers. -p Uses the poll command to request full routing information, in- stead of the default request command. -r addr Ask about the route to destination addr. -t op Change tracing, where op is one of the following. Requests from processes not running with UID 0 or on distant networks are gen- erally ignored by the daemon except for a message in the system log. dump Dumps the daemon's routing table to the current tracefile. more Increases the debugging level. off Turns off tracing. on=tracefile Turn tracing on into the specified file. That file must usually have been specified when the daemon was started or be the same as a fixed name, often /etc/routed.trace. -w timeout Changes the delay for an answer from each host. By default, each host is given 15 seconds to respond.
routed(8) Routing Information Protocol, RIPv1, RFC 1058, June 1988. Routing Information Protocol, RIPv2, RFC 1723, November 1994. MirOS BSD #10-current June 1, 1996 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.