RPC.LOCKD(8) BSD System Manager's Manual RPC.LOCKD(8)
rpc.lockd - NFS file locking daemon
rpc.lockd [-d [debug_level]]
rpc.lockd is a daemon which provides file- and record-locking services in an NFS environment. The options are as follows: -d [debug_level] Write debugging information to syslog, recording all RPC transac- tions to the daemon. These messages are logged with level LOG_DEBUG and facility LOG_DAEMON. If debug_level is not speci- fied, level 1 is assumed, giving one log line per protocol opera- tion. Higher debug levels can be specified, causing display of operation arguments and internal operations of the daemon. Error conditions are logged to syslog, irrespective of the debug level, using log level LOG_ERR and facility LOG_DAEMON. The rpc.lockd daemon must NOT be invoked by inetd(8) because the protocol assumes that the daemon will run from system start time. Instead, it should be run from rc(8) after the network has been started.
/usr/include/rpcsvc/nlm_prot.x RPC protocol specification for the net- work lock manager protocol.
The implementation is based on the specification in X/Open CAE Specifica- tion C218, "Protocols for X/Open PC Interworking: XNFS, Issue 4", ISBN 1 872630 66 9
The current implementation provides only the server side of the protocol (i.e., clients running other OS types can establish locks on an OpenBSD fileserver, but there is currently no means for an OpenBSD client to es- tablish locks). Versions 1, 2 and 3 of the protocol are supported. However, only versions 2 (Unix systems) and 3 (PC-NFS clients) seem to be in common use - the version 1 support has not been tested due to the lack of version 1 clients against which to test. MirOS BSD #10-current September 24, 1995 1
Generated on 2013-04-27 00:20:00 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.