PORTMAP(8) BSD System Manager's Manual PORTMAP(8)
portmap - DARPA port to RPC program number mapper
portmap is a server that converts RPC program numbers into DARPA protocol port numbers. It must be running in order to make RPC calls. When an RPC server is started, it will tell portmap what port number it is listening to, and what RPC program numbers it is prepared to serve. When a client wishes to make an RPC call to a given program number, it will first contact portmap on the server machine, port PMAP_PORT (defined in <rpc/pmap_prot.h> to 111) to determine the port number where RPC pack- ets should be sent. portmap must be started before any RPC servers are invoked. Normally portmap forks and dissociates itself from the terminal like any other daemon. portmap then logs errors using syslog(3). Option available: -d (debug) prevents portmap from running as a daemon, and causes er- rors and debugging information to be printed to the standard er- ror output.
inetd.conf(5), inetd(8), rpcinfo(8)
The portmap command appeared in 4.3BSD
If portmap crashes, all servers must be restarted. MirOS BSD #10-current March 16, 1991 1
Generated on 2015-10-06 19:36:22 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.