MOUNT_KERNFS(8) BSD System Manager's Manual MOUNT_KERNFS(8)
mount_kernfs - mount the /kern file system
mount_kernfs [-o options] /kern mount_point
The mount_kernfs command attaches an instance of the kernel parameter namespace to the global filesystem namespace. The conventional mount point is /kern. This command is invoked by mount(8) when using the syntax mount [options] -t kernfs /kern mount_point This command is normally executed by mount(8) at boot time. The filesystem includes several regular files which can be read, some of which can also be written. The contents of the files are in a machine- independent format, either a string, or an integer in decimal ASCII. Where numbers are returned, a trailing newline character is also added. The options are as follows: -o options Options are specified with a -o flag followed by a comma separat- ed string of options. See the mount(8) man page for possible op- tions and their meanings. Statistics reported by df(1) on the /kern filesystem will indicate the amount of unwired/physical memory instead of 'disk space', and the number of vnodes used/allocated instead of 'inodes'. The filesystem's block size is the system's page size.
boottime Time at which the system was last booted (decimal ASCII). byteorder _BYTE_ORDER for this kernel. copyright Kernel copyright message. domainname The domainname, with a trailing newline. Behaves like a host- name. hostname The hostname, with a trailing newline. The hostname can be changed by writing to this file. A trailing newline will be stripped from the hostname being written. hz Frequency of the system clock (decimal ASCII). ipsec The currently configured IPsec Security Associations. loadavg The 1, 5 and 15 minute load average in kernel fixed-point format. The final integer is the fix-point scaling factor. All numbers are in decimal ASCII. machine Architecture this kernel was compiled for. model Model of the processor this machine is running on. msgbuf Kernel message buffer, also read by syslogd(8), through the log device, and by dmesg(8). ncpu Number of CPUs in this machine. osrelease OS release number. osrev OS revision number (BSD from <sys/param.h>). ostype OS type for this kernel ("OpenBSD"). pagesize Machine pagesize (decimal ASCII). physmem Number of pages of physical memory in the machine (decimal ASCII). posix _POSIX_VERSION for this kernel. rootdev Root device. rrootdev Raw root device. time Second and microsecond value of the system clock. Both numbers are in decimal ASCII. usermem Number of pages of physical memory available for user processes. version Kernel version string. The head line for /etc/motd can be generated by running: "sed 1q /kern/version".
mount(2), fstab(5), dmesg(8), mount(8), syslogd(8), umount(8)
The mount_kernfs utility first appeared in 4.4BSD.
This filesystem may not be NFS-exported. Due to non-atomic operations and the potential for race conditions, pro- grams should not depend on information obtained from this filesystem. MirOS BSD #10-current March 27, 1994 1
Generated on 2015-07-19 22:36:15 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.