MODLOAD(8) BSD System Manager's Manual MODLOAD(8)
modload - load a kernel module
modload [-dnvsS] [-A kernel] [-e entry] [-p postinstall] [-o output_file] input_file
The modload utility loads a loadable kernel module into a running system. The input file is an object file (.o or .ko file). The options to modload are as follows: -d Debug. Used to debug modload itself. -n Do everything, except calling the module entry point (and any post-install program). -v Print comments about the loading process. -s Do not load symbols from the kernel module. -S Do not remove the temporary object file. By default, the ld(1) output is removed after being loaded into the kernel. -A kernel Specify the file that is passed to the linker to resolve module references to external symbols. The symbol file must be for the currently running kernel or the module is likely to crash the system. -e entry Specify the module entry point. This is passed by modload to ld(1) when the module is linked. The default module entry point name is 'xxxinit'. If 'xxxinit' cannot be found, an attempt to use '<module_name>_lkmentry' will be made, where <module_name> is the filename being loaded without the '.o' or '.ko'. -p postinstall Specify the name of a shell script or program that will be exe- cuted if the module is successfully loaded. It is always passed the module id (in decimal) and module type (in hexadecimal) as the first two arguments. For loadable drivers, the third argument is the block or character major device number. For a loadable system call, the third argument is the system call number. -o output_file Specify the name of the output file that is produced by the link- er.
/bsd default file passed to the linker to resolve external references in the module /usr/include/sys/lkm.h file containing definitions of module types
The modload utility exits with a status of 0 on success and with a nonzero status if an error occurs.
ld(1), lkm(4), modstat(8), modunload(8)
The modload command was designed to be similar in functionality to the corresponding command in SunOS 4.1.3.
Terrence R. Lambert <firstname.lastname@example.org>
• The loadable device driver framework can only reserve either a char- acter or block device entry, not both. • Loading the symbol table is expensive in terms of space: it presently duplicates all the kernel symbols for each lkm loaded with -s. MirOS BSD #10-current April 30, 1999 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.