EEPROM(8) BSD System Manager's Manual EEPROM(8)
eeprom - display or modify contents of the EEPROM or OpenPROM
eeprom [-] [-c] [-f device] [-i] [-v] [-N system] [field[=value] ...]
eeprom provides an interface for displaying and changing the contents of the EEPROM or OpenPROM. Without any arguments, eeprom will list all of the known fields and their corresponding values. When given the name of a specific field, eeprom will display that value or set it if the field name is followed by "=" and a value. Only the superuser may modify the contents of the EEPROM or OpenPROM. The options are as follows: - Commands are taken from stdin and displayed on stdout. -c eeprom will fix incorrect checksum values and exit. This flag is quietly ignored on systems with an OpenPROM. -f device On systems with an EEPROM, use device instead of the default /dev/eeprom. On systems with an OpenPROM, use device instead of the default /dev/openprom. -i If checksum values are incorrect, eeprom will ignore them and continue after displaying a warning. This flag is quietly ignored on systems with an OpenPROM. -v On systems with an OpenPROM, be verbose when setting a value. Systems with an EEPROM are always verbose. -N system Use the system image system instead of the default /bsd.
The following fields and values are for systems with an EEPROM: hwupdate A valid date, such as "7/12/95". The strings "today" and "now" are also acceptable. memsize How much memory, in megabytes, is installed in the system. memtest How much memory, in megabytes, is to be tested upon power-up. scrsize The size of the screen. Acceptable values are "1024x1024", "1152x900", "1600x1280", and "1440x1440". watchdog_reboot If true, the system will reboot upon reset. Otherwise, the system will fall into the monitor. default_boot If true, the system will use the boot device stored in bootdev. bootdev Specifies the default boot device in the form cc(x,x,x), where "cc" is a combination of two letters such as "sd" or "le" and each "x" is a hexadecimal number between 0 and ff, less the prepending "0x". kbdtype This value is "0" for all Sun keyboards. console Specifies the console type. Valid values are "b&w", "ttya", "ttyb", "color", and "p4opt". keyclick If true, the keys click annoyingly. diagdev This is a string very similar to that used by bootdev. It specifies the default boot device when the diagnos- tic switch is turned on. diagpath A 40-character, NULL-terminated string specifying the kernel or stand-alone program to load when the diag- nostic switch is turned on. columns An 8-bit integer specifying the number of columns on the console. rows An 8-bit integer specifying the number of rows on the console. ttya_use_baud Use the baud rate stored in ttya_baud instead of the default 9600. ttya_baud A 16-bit integer specifying the baud rate to use on ttya. ttya_no_rtsdtr If true, disables RTS/DTR. ttyb_use_baud Similar to ttya_use_baud, but for ttyb. ttyb_baud Similar to ttya_baud, but for ttyb. ttyb_no_rtsdtr Similar to ttya_no_rtsdtr, but for ttyb. banner An 80-character, NULL-terminated string to use at power-up instead of the default Sun banner. Note that the secure, bad_login, and password fields are not currently supported. Since the OpenPROM is designed such that the field names are arbitrary, explaining them here is dubious. Below are field names and values that one is likely to see on a system with an OpenPROM. NOTE: this list may be incomplete or incorrect due to differences between revisions of the Open- PROM. sunmon-compat? If true, the old EEPROM-style interface will be used while in the monitor, rather than the OpenPROM-style interface. selftest-#megs A 32-bit integer specifying the number of mega- bytes of memory to test upon power-up. oem-logo A 64bitx64bit bitmap in Sun Iconedit format. To set the bitmap, give the pathname of the file containing the image. NOTE: this property is not yet supported. oem-logo? If true, enables the use of the bitmap stored in oem-logo rather than the default Sun logo. oem-banner A string to use at power-up, rather than the de- fault Sun banner. oem-banner? If true, enables the use of the banner stored in oem-banner rather than the default Sun banner. ttya-mode A string of five comma separated fields in the format "9600,8,n,1,-". The first field is the baud rate. The second field is the number of data bits. The third field is the parity; acceptable values for parity are "n" (none), "e" (even), "o" (odd), "m" (mark), and "s" (space). The fourth field is the number of stop bits. The fifth field is the "handshake" field; acceptable values are "-" (none), "h" (RTS/CTS), and "s" (XON/XOFF). ttya-rts-dtr-off If true, the system will ignore RTS/DTR. ttya-ignore-cd If true, the system will ignore carrier detect. ttyb-mode Similar to ttya-mode, but for ttyb. ttyb-rts-dtr-off Similar to ttya-rts-dtr-off, but for ttyb. ttyb-ignore-cd Similar to ttya-ignore-cd, but for ttyb. sbus-probe-list Four digits in the format "0123" specifying which order to probe the sbus at power-up. It is un- likely that this value should ever be changed. screen-#columns An 8-bit integer specifying the number of columns on the console. screen-#rows An 8-bit integer specifying the number of rows on the console. auto-boot? If true, the system will boot automatically at power-up. watchdog-reboot? If true, the system will reboot upon reset. Oth- erwise, the system will fall into the monitor. input-device One of the strings "keyboard", "ttya", or "ttyb" specifying the default console input device. output-device One of the strings "screen", "ttya", or "ttyb" specifying the default console output device. keyboard-click? If true, the keys click annoyingly. sd-targets A string in the format "31204567" describing the translation of physical to logical target. st-targets Similar to sd-targets, but for tapes. The default translation is "45670123". scsi-initiator-id The SCSI ID of the on-board SCSI controller. hardware-revision A 7-character string describing a date, such as "25May95". last-hardware-update Similar to hardware-revision, describing when the CPU was last updated. diag-switch? If true, the system will boot and run in diagnos- tic mode. local-mac-address? When set to false, all Ethernet devices will use the same system default MAC address. When true, Ethernet devices which have a unique MAC address will use it rather than the system default MAC address. This option only really affects FCode- based Ethernet devices. In reality, this means that on Sparc machines with an OpenPROM, only hme(4) Ethernet devices respect this setting. On Sparc64, all on-board devices, as well as plug-in hme(4) boards, will respect this setting; other hardware will not.
/dev/eeprom the EEPROM device on systems with an EEPROM /dev/openprom the OpenPROM device on systems with an OpenPROM
The fields and their values are not necessarily well defined on systems with an OpenPROM. Your mileage may vary. There are a few fields known to exist in some revisions of the EEPROM and/or OpenPROM that are not yet supported. Most notable are those relat- ing to password protection of the EEPROM or OpenPROM. Avoid gratuitously changing the contents of the EEPROM. It has a limited number of write cycles. The date parser isn't very intelligent. MirOS BSD #10-current May 25, 1995 3
Generated on 2013-09-18 04:33:42 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.