DHCRELAY(8) BSD System Manager's Manual DHCRELAY(8)
dhcrelay - Dynamic Host Configuration Protocol Relay Agent
dhcrelay [-d] -i interface server1 [... serverN]
The dhcrelay utility provides a means for relaying DHCP and BOOTP re- quests from a subnet to which no DHCP server is directly connected to one or more DHCP servers on other subnets. dhcrelay listens for DHCP requests on a given interface. When a query is received, dhcrelay forwards it to the list of DHCP servers specified on the command line. When a reply is received, it is broadcast or unicast on the network from whence the original request came. The name of at least one DHCP server to which DHCP and BOOTP requests should be relayed, as well as the name of the network interface that dhcrelay should attempt to configure, must be specified on the command line. The options are as follows: -d dhcrelay normally runs in the foreground until it has configured an interface, and then reverts to running in the background. This option forces dhcrelay to always run as a foreground process. -i interface The name of the network interface that dhcrelay should attempt to configure.
dhclient(8), dhcpd(8) RFC 2132, RFC 2131.
dhcrelay was written by Ted Lemon <firstname.lastname@example.org>. The current implementation was reworked by Henning Brauer <email@example.com>.
Relayed DHCP traffic could actually safely be protected by IPsec but, like dhcpd(8) and dhclient(8), dhcrelay will bypass IPsec for all its traffic. MirOS BSD #10-current April 12, 2004 1
Generated on 2014-02-10 02:47:05 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.