AC(8) BSD System Manager's Manual AC(8)
ac - connect time accounting
ac [-dp] [-t tty] [-w wtmp] [users ...]
If the file /var/log/wtmp exists, a record of individual login and logout times are written to it by login(1) and init(8), respectively. ac exam- ines these records and writes the accumulated connect time for all logins to the standard output. The options are as follows: -d Display the connect times in 24 hour chunks. -p Print individual users' totals. -t tty Only do accounting logins on certain ttys. The tty specification can start with '!' to indicate not this tty and end with '*' to indicate all similarly named ttys. Multiple -t flags may be specified. -w wtmp Read connect time data from wtmp instead of the default file, /var/log/wtmp. users ... Display totals for the given individuals only. If no arguments are given, ac displays the total connect time for all ac- counts with login sessions recorded in wtmp. The default wtmp file will increase without bound unless it is truncated. It is normally truncated by the daily scripts run by cron(8), which rename and rotate the wtmp files, keeping a week's worth of data on hand. No login or connect time accounting is performed if /var/log/wtmp does not exist. For example, $ ac -p -t "ttyd*" > modems $ ac -p -t "!ttyd*" > other allows times recorded in modems to be charged out at a different rate than other. The ac utility exits 0 on success or >0 if a fatal error occurred.
/var/log/wtmp connect time accounting file /var/log/wtmp.[0-7] rotated files
login(1), utmp(5), init(8), sa(8)
An ac command appeared in Version 6 AT&T UNIX. This version of ac was written for NetBSD 0.9A from the specification provided by various sys- tems' manual pages. MirOS BSD #10-current March 15, 1994 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.