MAKEDEV(8) BSD System Manager's Manual (SPARC) MAKEDEV(8)
MAKEDEV - create system and device special files
MAKEDEV name [...]
The shell script MAKEDEV, found in the /dev directory, is used to create various special files. See intro(4) for a more complete discussion of special files. MAKEDEV takes any number of device names as arguments, where the names are the common abbreviation for the device or group of devices. Where a device name is followed by a star '*', the star must be replaced by a unit number. If units are expected for a device but not provided, MAKEDEV will supply the standard numbers in most cases. The sparc supports the following devices: Special device names all Creates special files for all devices on sparc. ramdisk Ramdisk kernel devices. std Creates the 'standard' devices (console, drum, klog, kmem, ksyms, mem, null, stderr, stdin, stdout, tty, zero) which are absolutely necessary for the system to function properly. local Creates configuration-specific devices, by invoking the shell file MAKEDEV.local. Disks ccd* Concatenated disk devices, see ccd(4). cd* ATAPI and SCSI CD-ROM drives, see cd(4). fd* Floppy disk drives (3 1/2", 5 1/4"), see fd(4). presto* Prestoserve NVRAM memory, see presto(4). sd* SCSI disks, including flopticals, see sd(4). raid* RAIDframe disk devices, see raid(4). rd* "rd" pseudo-disks, see rd(4). vnd* "file" pseudo-disk devices, see vnd(4). xd* Xylogic 753/7053 disks, see xd(4). xy* Xylogic 450/451 disks, see xy(4). Tapes ch* SCSI media changers, see ch(4). st* SCSI tape drives, see st(4). Terminal ports cua[a-z]* Zilog 8530 serial ports, see zs(4). tty[a-z]* Zilog 8530 serial ports, see zs(4). magma* Magma multiport cards, see magma(4). spif* "spif" multiport cards, see spif(4). Pseudo terminals ptm pty master device, see ptm(4). pty* Set of 62 master pseudo terminals, see pty(4). tty* Set of 62 slave pseudo terminals, see tty(4). Printers bpp* Parallel port, see bpp(4). bppmag[mno] Magma parallel port, see magma(4). bpp[jkl] "spif" parallel port, see spif(4). Console ports ttyC0 Minimal wscons devices, see wscons(4). ttyC-F* wscons display devices, see wsdisplay(4). wskbd* wscons keyboards, see wskbd(4). wsmux wscons keyboard/mouse mux devices, see wsmux(4). Pointing devices wsmouse* wscons mice, see wsmouse(4). Special purpose devices audio* Audio devices, see audio(4). bpf* Berkeley Packet Filter, see bpf(4). fd fd/* nodes for fdescfs, see mount_fdesc(8). lkm Loadable kernel modules interface, see lkm(4). openprom PROM settings, see openprom(4). pf* Packet Filter, see pf(4). *random In-kernel random data source, see random(4). ss* SCSI scanners, see ss(4). systrace* System call tracing device, see systrace(4). tun* Network tunnel driver, see tun(4). uk* Unknown SCSI devices, see uk(4).
/dev The special file directory.
intro(4), config(8), mknod(8) MirOS BSD #10-current February 22, 2009 1
Generated on 2012-09-10 15:20:00 by $MirOS: src/scripts/roff2htm,v 1.73 2012/07/01 16:04:30 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2011 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.