MAILADDR(7) BSD Reference Manual MAILADDR(7)
mailaddr - mail addressing description
Mail addresses are based on the Internet protocol listed at the end of this manual page. These addresses are in the general format user@domain where a domain is a hierarchical dot separated list of subdomains. For example, a valid address is: eric@CS.Berkeley.EDU Unlike some other forms of addressing, domains do not imply any routing. Thus, although this address is specified as an Internet address, it might travel by an alternate route if that were more convenient or efficient. For example, at Berkeley, the associated message would probably go directly to CS over the Ethernet rather than going via the Berkeley In- ternet gateway.
Under certain circumstances it may not be necessary to type the entire domain name. In general, anything following the first dot may be omitted if it is the same as the domain from which you are sending the message. For example, a user on "calder.berkeley.edu" could send to "eric@CS" without adding the "berkeley.edu" since it is the same on both sending and receiving hosts.
Certain old address formats are converted to the new format to provide compatibility with the previous mail system. In particular, user@host and email@example.com are allowed; host.domain!user is converted to firstname.lastname@example.org and host!user is converted to user@host.UUCP This is normally converted back to the "host!user" form before being sent on for compatibility with older UUCP hosts.
Domain names (i.e., anything after the "@" sign) may be given in any mix- ture of upper and lower case with the exception of UUCP hostnames. Most hosts accept any combination of case in user names, with the notable ex- ception of MULTICS sites.
Under some circumstances it may be necessary to route a message through several hosts to get it to the final destination. Normally this routing is done automatically, but sometimes it is desirable to route the message manually. Addresses which show these relays are termed "route-addrs". These use the syntax: <@hosta,@hostb:user@hostc> This specifies that the message should be sent to "hosta", from there to "hostb", and finally to "hostc". This path is forced even if there is a more efficient path to "hostc". Route-addrs occur frequently on return addresses, since these are gen- erally augmented by the software at each host. It is generally possible to ignore all but the "user@hostc" part of the address to determine the actual sender. [Note: The route-addr syntax is officially deprecated in RFC 1123 and should not be used.] Many sites also support the "percent hack" for simplistic routing: user%hostc%hostb@hosta is routed as indicated in the previous example.
Every site is required to have a user or user alias designated "postmaster" to which problems with the mail system may be addressed.
Some other networks can be reached by giving the name of the network as the last component of the domain. This is not a standard feature and may not be supported at all sites. For example, messages to CSNET or BITNET sites can often be sent to "user@host.CSNET" or "user@host.BITNET", respectively.
mail(1), sendmail(8) Crocker, D. H., Standard for the Format of Arpa Internet Text Messages, RFC 822.
mailaddr appeared in 4.2 BSD.
The RFC 822 group syntax ("group:user1,user2,user3;") is not supported except in the special case of "group:;" because of a conflict with old berknet-style addresses. Route-Address syntax is grotty. UUCP- and Internet-style addresses do not coexist politely. MirOS BSD #10-current June 16, 1993 1
Generated on 2015-04-13 10:26:13 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.