SPAMD.CONF(5) BSD Reference Manual SPAMD.CONF(5)
spamd.conf - configuration file read by spamd-setup(8) for spamd(8)
The spamd.conf file is read by spamd-setup(8) to configure blacklists and whitelists with corresponding pf(4) table entries for spamd(8). spamd.conf follows the syntax of configuration databases as documented in getcap(3). Example: all:\ :spews1:white:myblack: spews1:\ :black:\ :msg="SPAM. Your address %A is in the spews\ level 1 database\nsee http://www.spews.org/ask.cgi?x=%A\n":\ :method=http:\ :file=www.spews.org/spews_list_level1.txt: white:\ :white:\ :method=file:\ :file=/var/mail/mywhite.txt: myblack:\ :black:\ :msg=/var/mail/myblackmsg.txt:\ :method=file:\ :file=/var/mail/myblack.txt: The default configuration file must include the entry all which specifies the order in which named blacklists and whitelists are to be applied. The addresses in a whitelist are removed from the preceding blacklist. In the above example, if the address was present in all three lists, blacklists spews1 and myblack, as well as whitelist white, the address would be re- moved from blacklist spews1 by the subsequent white whitelist. However, the address would not be removed from the myblack blacklist. To remove all the addresses in white from myblack, the configuration all:\ :spews1:white:myblack:white: would be used instead. Blacklists and whitelists are then constructed by name; blacklists are identified by the capability black, and whitelists by the capability white. The source of the addresses for blacklists and whitelists is specified using the method and file capability entries. method specifies the method by which to retrieve a file containing a list of addresses that consist of the blacklist or whitelist, and may be http, ftp, file or exec. The methods http, ftp and file capabilities will make spamd.conf retrieve a list of addresses specified in the location in the file capability for the list. The exec capability will make spamd.conf spawn the program with arguments indicated in the file capability for the list, and reads a list of addresses from the output of the program. The format of the list of addresses is expected to consist of one network block or address per line (optionally followed by a space and text that is ignored). Comment lines beginning with # are ignored. Network blocks may be specified in any of the formats as in the following example: # CIDR format 192.168.20.0/24 # A start - end range 192.168.21.0 - 192.168.21.255 # As a single IP address 192.168.23.1 Each blacklist must include a message, specified in the msg capability as a string. If the msg string is enclosed in double quotes, the characters in the quoted string are escaped as specified in getcap(3) with the ex- ception that a colon (:) is allowed in the quoted string. The resulting string is used as the message. Alternatively, if the msg string is not specified in quotes, it is assumed to be a local filename from which the message text may be read. The message is configured in spamd(8) to be displayed in the SMTP dialo- gue to any connections that match addresses in the blacklist. The se- quence \" in the message will produce a double quote in the output. The sequence %% will produce a single % in the output, and the sequence %A will be expanded in the message by spamd(8) to display the connecting IP address in the output.
ftp(1), pf(4), spamd(8), spamd-setup(8) MirOS BSD #10-current March 8, 2003 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.