SENSORSD.CONF(5) BSD Reference Manual SENSORSD.CONF(5)
sensorsd.conf - configuration file for sensorsd(8)
The sensorsd.conf file is read by sensorsd(8) to configure hardware sen- sor monitoring. Each entry represents one sensor and may specify high and low limits. If the limits are crossed, sensorsd(8)'s alert functionality is triggered and a command, if specified, is executed. sensorsd.conf follows the syntax of configuration databases as documented in getcap(3). Example: hw.sensors.0:high=80C:command=/etc/sensorsd/log_warning %1 %2 hw.sensors.1:high=170F hw.sensors.2:low=4.8V:high=5.2V hw.sensors.3:low=1000:high=8000 The values for temperature sensors can be given in degrees Celsius or Fahrenheit, for voltage sensors in volts, and fan speed sensors take a unit-less number representing RPM. The command is executed on transitions out of, and back into, given lim- its. Tokens in the command are substituted as follows: %1 with the sensor number, %2 with the sensor's current value, %3 with the sensor's low lim- it, and %4 with the sensor's high limit.
/etc/sensorsd.conf Configuration file for sensorsd(8).
The sensorsd.conf file format first appeared in OpenBSD 3.5. MirOS BSD #10-current March 15, 2005 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.