PNG(5) BSD Reference Manual PNG(5)
png - Portable Network Graphics format
The png library contains functions dealing with files in the PNG format. PNG (Portable Network Graphics) is an extensible file format for the lossless, portable, well-compressed storage of raster images. PNG pro- vides a patent-free replacement for GIF and can also replace many common uses of TIFF. Indexed-colour, grayscale, and truecolour images are sup- ported, plus an optional alpha channel. Sample depths range from 1 to 16 bits. PNG is designed to work well in online viewing applications, such as the World Wide Web, so it is fully streamable with a progressive display op- tion. PNG is robust, providing both full file integrity checking and fast, simple detection of common transmission errors. Also, PNG can storegamma and chromaticity data for improved colour matching on hetero- geneous platforms.
The PNG specification, second edition, November 2003 http://www.w3.org/TR/2003/REC-PNG-20031110/ The PNG 1.2 specification, July 1999 http://www.libpng.org/pub/png The PNG 1.0 specification, October 1996 RFC 2083, ftp://ftp.rfc-editor.org:/in-notes/rfc2083.txt A W3C draft is at http://www.w3.org/TR/REC-png.html
The png library became part of the base system with MirOS #8.
The current libpng maintainer is Glenn Randers-Pehrson <email@example.com>. This manual page and the MirOS adaptions are courtesy of Thorsten "mirabilos" Glaser <firstname.lastname@example.org>. For detailed authorship and copyright information, refer to /usr/include/png.h. MirOS BSD #10-current October 22, 2008 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.