WSMUX(4) BSD Programmer's Manual WSMUX(4)
wsmux - console keyboard/mouse multiplexor for wscons
wskbd* at ... mux N wsmouse* at ... mux N pseudo-device wsmux [count]
The wsmux is a pseudo-device driver that allows several wscons(4) input devices to have their events multiplexed into one stream. The typical usage for this device is to have two multiplexors, one for mouse events and one for keyboard events. All wsmouse(4) devices should direct their events to the mouse mux (normally 0) and all keyboard dev- ices, except the console, should direct their events to the keyboard mux (normally 1). A device will send its events to the mux indicated by the mux locator. If none is given the device will not use a multiplexor. The keyboard multiplexor should be connected to the display, using the wsconscfg(8) command. It will then receive all keystrokes from all key- boards and, furthermore, keyboards can be dynamically attached and de- tached without further user interaction. In a similar way, the window system will open the mouse multiplexor and receive all mouse events; mice can also be dynamically attached and detached. It is also possible to inject events into a multiplexor from a user pro- gram. This is used by the wsmoused(8) daemon to take data from a mouse connected to a serial port and make it appear on the standard mouse mux.
/dev/wsmouse /dev/wskbd /usr/include/dev/wscons/wsconsio.h
intro(4), wscons(4), wsdisplay(4), wskbd(4), wsmouse(4), wsconscfg(8), wsconsctl(8), wsmoused(8) MirOS BSD #10-current July 26, 1999 1
Generated on 2014-02-10 02:47:05 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.