WSKBD(4) BSD Programmer's Manual WSKBD(4)
wskbd - generic keyboard support in wscons
wskbd* at pckbd? console ? mux 1 wskbd* at gsckbd? console ? mux 1 (hppa) (PS/2 keyboard) wskbd* at ukbd? console ? mux 1 (USB keyboard) wskbd* at akbd? console ? mux 1 (Apple ADB keyboard) wskbd* at comkbd? console ? mux 1 wskbd* at zskbd? console ? mux 1 (Sun serial keyboard) wskbd* at hilkbd? console ? mux 1 (HIL keyboard)
The wskbd driver handles common tasks for keyboards within the wscons(4) framework. It is attached to the hardware specific keyboard drivers and provides their connection to "wsdisplay" devices and a character device interface. The common keyboard support consists of: • Mapping from keycodes (defined by the specific keyboard driver) to keysyms (hardware independent, defined in /usr/include/dev/wscons/wsksymdef.h). • Handling of "compose" sequences. Characters commonly not present as separate keys on keyboards can be generated after either a special "compose" key is pressed or a "dead accent" character is used. • Certain translations, like turning an "ALT" modifier into an "ESC" prefix. • Automatic key repetition ("typematic"). • Parameter handling for "keyboard bells". • Generation of "keyboard events" for use by X servers. The wskbd driver provides a number of ioctl functions to control key maps and other parameters. These functions are accessible through the associ- ated "wsdisplay" device as well. A complete list is in /usr/include/dev/wscons/wsconsio.h. The wsconsctl(8) utility allows ac- cess to key maps and other variables. The console locator in the configuration line refers to the device's use as input part of the operating system console. A device specification containing a positive value here will only match if the device is in use as system console. (The console device selection in early system startup is not influenced.) This way, the console device can be connected to a known wskbd device instance. The wskbd driver traps certain key sequences intended to perform special functions. The Ctrl+Alt+Esc sequence will initiate the ddb(4) kernel de- bugger if the "ddb.console" sysctl(8) variable is set. When attached to a wsdisplay(4) device, Ctrl+Alt+Fx switches virtual terminals and the Shift+PgUp and Shift+PgDn combinations provide scrollback functionality if the underlying hardware driver supports it.
/dev/wskbd* /usr/include/dev/wscons/wsksymdef.h /usr/include/dev/wscons/wsconsio.h
akbd(4), comkbd(4), gsckbd(4), hilkbd(4), intro(4), pckbd(4), ukbd(4), wscons(4), wsmux(4), zskbd(4), wsconsctl(8) MirOS BSD #10-current February 11, 2003 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.