WSDISPLAY(4) BSD Programmer's Manual WSDISPLAY(4)
wsdisplay - generic display device support in wscons
wsdisplay* at vga? console ? (VGA textmode display on ISA or PCI) wsdisplay* at pcdisplay? console ? (generic PC (ISA) display) wsdisplay* at vgafb? console ? (VGA graphics display on PCI, as found on macppc and sparc64 platforms) wsdisplay* at tga? console ? (DEC TGA display, alpha only) wsdisplay* at sti? console ? (HP CRX and Visualize series framebuffers) wsdisplay* at agten? console ? wsdisplay* at bwtwo? console ? wsdisplay* at cgtwo? console ? wsdisplay* at cgthree? console ? wsdisplay* at cgfour? console ? wsdisplay* at cgsix? console ? wsdisplay* at cgeight? console ? wsdisplay* at cgtwelve? console ? wsdisplay* at cgfourteen? console ? wsdisplay* at mgx? console ? wsdisplay* at pninek? console ? wsdisplay* at pnozz? console ? wsdisplay* at rfx? console ? wsdisplay* at tcx? console ? wsdisplay* at tvtwo? console ? wsdisplay* at vigra? console ? wsdisplay* at zx? console ? (sparc and/or sparc64 framebuffers) wsdisplay* at creator? console ? (sparc64 framebuffers) wsdisplay0 at smg? console ? (VAXstation small monochrome display) option WSDISPLAY_DEFAULTSCREENS=N
The wsdisplay driver is an abstraction layer for display devices within the wscons(4) framework. It attaches to the hardware specific display device driver and makes it available as text terminal or graphics inter- face. A display device can have the ability to display characters on it (without help of an X server), either directly by hardware or through software drawing pixel data into the display memory. Such displays are called "emulating", the wsdisplay driver will connect a terminal emula- tion module and provide a tty-like software interface. In contrary, non- emulating displays can only be used by special programs like X servers. The console locator in the configuration line refers to the device's use as output part of the operating system console. A device specification containing a positive value here will only match if the device is in use as system console. (The console device selection in early system startup is not influenced.) This way, the console device can be connected to a known wsdisplay device instance. (Naturally, only "emulating" display devices are usable as console.) The logical unit of an independent contents displayed on a display (some- times referred to as "virtual terminal") is called a "screen" here. If the underlying device driver supports it, multiple screens can be used on one display. (As of this writing, only the vga(4) and the VAX "smg" display drivers provide this ability.) Screens have different minor dev- ice numbers and separate tty instances. One screen possesses the "focus", this means it is displayed on the display and its tty device will get the keyboard input. (In some cases, if no screen is set up or if a screen was just deleted, it is possible that no focus is present at all.) The focus can be switched by either special keyboard input (typically CTL-ALT-Fn) or an ioctl command issued by a user program. Screens are set up or deleted through the /dev/ttyCcfg control device (preferably using the wsconscfg(8) utility). Alternatively, the compile-time option WSDISPLAY_DEFAULTSCREENS=N will set up N screens of the display driver's default type and using the system's default terminal emulator at autocon- figuration time. In addition and with help from backend drivers the following features are also provided: • Loading, deleting and listing the loaded fonts. • Browsing backwards in the screen output, the size of the buffer for saved text is defined by the particular hardware driver. • Blanking the screen by timing out on inactivity in the screen holding the input focus. Awakening activities consist of: • pressing any keys on the keyboard; • moving or clicking the mouse; • any output to the screen. Blanking the screen is usually done by disabling the horizontal sync signal on video output, but may also include blanking the vertical sync in which case most monitors go into power saving mode. See wsconsctl(8) for controlling variables. Consult the back-end drivers' documentation for which features are sup- ported for each particular hardware type.
/dev/tty[C-F]* terminal devices (per screen) /dev/tty[C-F]cfg control device (per screen) /usr/include/dev/wscons/wsconsio.h
agten(4), bwtwo(4), cgeight(4), cgfour(4), cgfourteen(4), cgsix(4), cgthree(4), cgtwelve(4), cgtwo(4), creator(4), intro(4), mgx(4), pcdisplay(4), pninek(4), pnozz(4), rfx(4), sti(4), tcx(4), tga(4), tty(4), tvtwo(4), vga(4), vgafb(4), vigra(4), wscons(4), zx(4), wsconscfg(8), wsconsctl(8), wsfontload(8)
The wsdisplay code currently limits the number of screens on one display to 8. The terms "wscons" and "wsdisplay" are not cleanly distinguished in the code and in manual pages. "non-emulating" display devices are not tested. MirOS BSD #10-current February 29, 2004 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.