TX(4) BSD Programmer's Manual TX(4)
tx - SMC 9432 10/100 Mbps Ethernet driver
tx* at pci? dev ? function ?
The tx interface provides access to the 10Mb/s and 100Mb/s Ethernet net- works via the SMC EPIC chipset. This driver provides support for the SMC EtherPower II 10/100 Ethernet cards. Each of the host's network addresses is specified at boot time with an SIOCSIFADDR ioctl(2). The tx interface employs the address resolution protocol described in arp(4) to dynamically map between Internet and Eth- ernet addresses on the local network. When a tx interface is brought up, by default, it will attempt to auto- negotiate the link speed and duplex. The speeds, in order of attempt, are: 100Mb/s Full Duplex, 100Mb/s Half Duplex, 10 Mb/s Full Duplex, and 10 Mb/s Half Duplex. The tx supports several media types, which are selected via the ifconfig(8) command. The supported media types are: media autoselect Attempt to autoselect the media type (default) media 100baseFX mediaopt full-duplex Use 100baseFX (fiber), full duplex media 100baseFX [mediaopt half-duplex] Use 100baseFX (fiber), half duplex media 100baseTX mediaopt full-duplex Use 100baseTX, full duplex media 100baseTX [mediaopt half-duplex] Use 100baseTX, half duplex media 100baseTX mediaopt loopback Put the interface into loopback mode media 10baseT mediaopt full-duplex Use 10baseT, full duplex media 10baseT [mediaopt half-duplex] Use 10baseT, half duplex media 10baseT mediaopt loopback Put the interface into loopback mode
tx%d: device timeout %d packets The device stopped responding. Device and driver reset follows this error. tx%d: PCI fatal error occurred (%s) One of following errors occurred: PCI Target Abort, PCI Master Abort, Data Parity Error or Address Parity Error. Device and driver reset follows this error. tx%d: WARNING! no link established No media connected. Displayed at startup only. tx%d: cannot allocate mbuf header/cluster Failed to allocate memory for a received packet. Packet was dropped. tx%d: can't stop %s DMA While resetting, the driver failed to stop the device correctly.
arp(4), ifmedia(4), inet(4), intro(4), netintro(4), pci(4), hostname.if(5), ifconfig(8)
OpenBSD support for the tx first appeared in OpenBSD 2.4.
Multicast packet filtering is not supported. MirOS BSD #10-current September 21, 1998 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.