TCTRL(4) BSD Programmer's Manual (SPARC) TCTRL(4)
tctrl - Tadpole Microcontroller Interface
tctrl0 at obio0
The tctrl driver provides control over many functions on the Tadpole SPARCbook 3 series laptops, via their TS102 chip. The microcontroller is used to power the TFT display down when the laptop lid is closed and when the screen is blanked by the pninek(4) or pnozz(4) driver. The tctrl is also used to power the laptop off when the reboot(2) system call is used with the RB_POWERDOWN flag is set. The PCMCIA part of the controller is managed by the tslot(4) driver.
reboot(2), intro(4), pninek(4), pnozz(4), tslot(4) MirOS BSD #10-current June 22, 2003 1
Generated on 2013-09-18 04:33:42 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.