SK(4) BSD Programmer's Manual SK(4)
sk, skc - SysKonnect XMAC II and Marvell GMAC based gigabit ethernet
skc* at pci? dev ? function ? sk* at skc?
The sk driver provides support for SysKonnect based gigabit ethernet adapters and Marvell based gigabit ethernet adapters, including the fol- lowing: • SK-9821 SK-NET GE-T single port, copper adapter • SK-9822 SK-NET GE-T dual port, copper adapter • SK-9841 SK-NET GE-LX single port, single mode fiber adapter • SK-9842 SK-NET GE-LX dual port, single mode fiber adapter • SK-9843 SK-NET GE-SX single port, multimode fiber adapter • SK-9844 SK-NET GE-SX dual port, multimode fiber adapter • SK-9521 V2.0 single port, copper adapter (32-bit) • SK-9821 V2.0 single port, copper adapter • SK-9843 V2.0 single port, copper adapter • 3com 3c940 single port, copper adapter • Linksys EG1032v2, copper adapter • Linksys EG1064v2, copper adapter • D-Link DGE-530T, copper adapter • SMC 9452TX, copper adapter The SysKonnect based adapters consist of two main components: the XaQti Corp. XMAC II Gigabit MAC (sk) and the SysKonnect GEnesis controller ASIC (skc). The XMAC provides the Gigabit MAC and PHY support while the GEnesis provides an interface to the PCI bus, DMA support, packet buffer- ing and arbitration. The GEnesis can control up to two XMACs simultane- ously, allowing dual-port NIC configurations. The Marvell based adapters are a single integrated circuit, but are still presented as a separate MAC (sk) and controller ASIC (skc). At this time, there are no dual-port Marvell based NICs. The sk driver configures dual port SysKonnect adapters such that each XMAC is treated as a separate logical network interface. Both ports can operate independently of each other and can be connected to separate net- works. The SysKonnect driver software currently only uses the second port on dual port adapters for failover purposes: if the link on the primary port fails, the SysKonnect driver will automatically switch traffic onto the second port. The XaQti XMAC II supports full and half duplex operation with autonego- tiation. The XMAC also supports unlimited frame sizes. Support for jumbo frames is provided via the interface MTU setting. Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility configures the adapter to receive and transmit jumbo frames. Using jumbo frames can greatly improve performance for certain tasks, such as file transfers and data streaming. Hardware TCP/IP checksum offloading for IPv4 is supported. The following media types and options (as given to ifconfig(8)) are sup- ported: media autoselect Enable autoselection of the media type and options. The user can manually override the autoselected mode by adding media options to the appropriate hostname.if(5) file. media 1000baseSX mediaopt full-duplex Set 1000Mbps (Gigabit Ethernet) operation on fiber and force full-duplex mode. media 1000baseSX mediaopt half-duplex Set 1000Mbps (Gigabit Ethernet) operation on fiber and force half-duplex mode. media 1000baseT mediaopt full-duplex Set 1000Mbps (Gigabit Ethernet) operation and force full- duplex mode. For more information on configuring this device, see ifconfig(8). To view a list of media types and options supported by the card, try ifconfig -m <device>. For example, ifconfig -m sk0.
sk%d: couldn't map memory A fatal initialization error has occurred. sk%d: couldn't map ports A fatal initialization error has occurred. sk%d: couldn't map interrupt A fatal initialization error has occurred. sk%d: failed to enable memory mapping! The driver failed to initialize PCI shared memory mapping. This might happen if the card is not in a bus-master slot. sk%d: no memory for jumbo buffers! The driver failed to allocate memory for jumbo frames during initialization. sk%d: watchdog timeout The device has stopped responding to the network, or there is a problem with the network connection (cable).
arp(4), ifmedia(4), intro(4), netintro(4), pci(4), hostname.if(5), ifconfig(8) XaQti XMAC II datasheet, http://www.xaqti.com. SysKonnect GEnesis programming manual, http://www.syskonnect.com.
The sk device driver first appeared in FreeBSD 3.0, and OpenBSD support was added in OpenBSD 2.6.
The sk driver was written by Bill Paul <email@example.com>. MirOS BSD #10-current July 3, 1999 1
Generated on 2015-04-13 10:26:13 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.