SIOP(4) BSD Programmer's Manual SIOP(4)
siop - LSI/Symbios Logic/NCR 53c8xx SCSI driver
siop* at pci? dev ? function ? scsibus* at siop?
The siop driver provides support for following LSI/Symbios Logic/NCR 53c8xx and related SCSI controller chips: - 53c810, 53c810a and 53c815 (Fast SCSI) - 53c820, 53c825 and 53c825a (Fast-Wide SCSI) - 53c860 (Ultra SCSI) - 53c875 and 53c875j (Ultra-Wide SCSI) - 53c876 (Dual Ultra-Wide SCSI) - 53c885 (Ultra-Wide SCSI and Ethernet) - 53c895 and 53c895a (Ultra2-Wide SCSI) - 53c896 (PCI 64bit, dual Ultra2-Wide SCSI) - 53c1010 (PCI 64bit, dual Ultra3-Wide SCSI. NOTE: at this time siop supports at most Ultra2-Wide with this chip) - 53c1510D (dual Ultra2-Wide SCSI) siop replaces the older ncr driver which supported most of these devices. Older 53C700 and 53C710 controllers are supported by the oosiop(4) and osiop(4) drivers, respectively.
cd(4), ch(4), intro(4), ncr(4), oosiop(4), osiop(4), pci(4), scsi(4), sd(4), st(4), uk(4) http://www.lsilogic.com/
The siop driver first appeared in NetBSD 1.5, OpenBSD support was added in OpenBSD 2.9.
The siop driver was written by Manuel Bouyer <Manuel.Bouyer@lip6.fr> for NetBSD. It was ported to OpenBSD with 53c1010 support added by Ken Westerback <firstname.lastname@example.org> using code from the FreeBSD sym-2 driver written by Gerard Roudier <groudier@FreeBSD.org>. MirOS BSD #10-current March 12, 2004 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.