SF2R(4) BSD Programmer's Manual SF2R(4)
sf2r - SoundForte RadioLink SF16-FMR2 FM radio device driver
sf2r0 at isa? port 0x384 flags 0x00 radio* at sf2r?
The sf2r driver provides support for the SF16-FMR2 FM radio tuners. The SF16-FMR2 is a stereo FM tuner that can tune in the range 87.5 - 108.0 MHz, report signal status on the current frequency, force audio output to mono, perform hardware signal search, and has an internal AFC. The card is based on the TEA5757 chip; see radio(4) for details. The SF16-FMR2 cards take only one I/O port. The I/O port is set by the driver to the value specified in the configuration file and must be 0x384. The flags control the driver behavior. For example, with flags 0x01 the driver will assume that there is a TEA5759 chip. MediaForte made two variants of the SF16-FMR2 cards, the first one has an internal amplifier (PT2254A chip) of the output sound, the second one does not have such an amplifier. The current driver supports both vari- ants.
intro(4), isa(4), radio(4), radio(9)
The sf2r device driver appeared in OpenBSD 3.0.
The sf2r driver was written by Vladimir Popov <firstname.lastname@example.org> and Maxim Tsyplakov <email@example.com>. The man page was written by Vladimir Popov <firstname.lastname@example.org>. MirOS BSD #10-current October 8, 2001 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.