SES(4) BSD Programmer's Manual SES(4)
ses - SCSI Environmental Services Driver
ses* at scsibus? target ? lun ?
The ses driver provides support for all SCSI devices of the environmental services class that are attached to the system through a supported SCSI Host Adapter, as well as emulated support for SAF-TE (SCSI Accessible Fault Tolerant Enclosures). The environmental services class generally are enclosure devices that provide environmental information such as number of power supplies (and state), temperature, device slots, and so on. A SCSI Host adapter must also be separately configured into the system before a SCSI Environmental Services device can be configured.
The following ioctl(2) calls apply to SES devices. They are defined in the header file <scsi/ses.h>. SESIOC_GETNOBJ Used to find out how many SES objects are driven by this particular device instance. SESIOC_GETOBJMAP Read, from the kernel, an array of SES objects which contains the object identifier, which subenclosure it is in, and the SES type of the object. SESIOC_GETENCSTAT Get the overall enclosure status. SESIOC_SETENCSTAT Set the overall enclosure status. SESIOC_GETOBJSTAT Get the status of a particular object. SESIOC_SETOBJSTAT Set the status of a particular object. SESIOC_GETTEXT Get the associated help text for an object (not yet implemented). SES devices often have descriptive text for an object which can provide information such as location (e.g. "power supply left"). SESIOC_INIT Initialize the enclosure.
/dev/sesN The Nth SES device.
When the kernel is configured with DEBUG enabled, the first open to an SES device will spit out overall enclosure parameters to the console.
intro(4), scsi(4), getencstat(8), sesd(8), setencstat(8), setobjstat(8)
The ses driver was written for the SCSI subsystem by Matthew Jacob. This is the functional equivalent of a similar driver available in Solaris, Release 7. MirOS BSD #10-current February 22, 2000 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.