SCSI(4) BSD Programmer's Manual SCSI(4)
scsi - scsi system
scsibus at ... cd* at scsibus? target ? lun ? ch* at scsibus? target ? lun ? sd* at scsibus? target ? lun ? st* at scsibus? target ? lun ? ss* at scsibus? target ? lun ? uk* at scsibus? target ? lun ? ses* at scsibus? target ? lun ?
The SCSI system provides a uniform and modular system for the implementa- tion of drivers to control various scsi devices, and to utilize different scsi host adapters through host adapter drivers. When the system probes the SCSI busses, it attaches any devices it finds to the appropriate drivers. If no driver seems appropriate, then it attaches the device to the uk (unknown) driver so that user level scsi ioctls may still be per- formed against the device.
The option SCSIDEBUG enables the debug ioctl. All devices and the SCSI busses support boot time allocation so that an upper number of devices and controllers does not need to be configured; sd* at scsibus? target ? lun ? will suffice for any number of disk drivers. The devices are either wired so they appear as a particular device unit or counted so that they appear as the next available unused unit. To configure a driver in the kernel without wiring down the device use a config line similar to ch* at scsibus? target ? lun ? to include the changer driver. To wire down a unit use a config line similar to ch1 at scsibus0 target 4 lun 0 to assign changer 1 as the changer with SCSI ID 4, SCSI logical unit 0 on SCSI bus 0. Individual scsibuses can be wired down to specific controllers with a config line similar to scsibus0 at ahc0 which assigns scsi bus 0 to the first unit using the ahc driver. For controllers supporting more than one bus, the particular bus can be specified as in scsibus3 at ahc1 bus 1 which assigns scsibus 1 to the second bus probed on the ahc1 device. When there is a mixture of wired down and counted devices then the count- ing begins with the first non-wired down unit for a particular type. That is, if a disk is wired down as disk sd1 at scsibus? target ? lun ?, then the first non-wired disk shall come on line as sd2.
There are a number of ioctls that work on any SCSI device. They are de- fined in <sys/scsiio.h> and can be applied against any scsi device that permits them. For the tape, it must be applied against the control dev- ice. See the manual page for each device type for more information about how generic scsi ioctls may be applied to a specific device. SCIOCRESET* Reset a device. SCIOCDEBUG Turn on debugging. All scsi operations originating from this device's driver will be traced to the console, along with other information. Debugging is controlled by four bits, described in the header file. If no debugging is configured into the kernel, debugging will have no ef- fect. SCSI debugging is controlled by the configuration option SCSIDEBUG. SCIOCCOMMAND Take a scsi command and data from a user process and ap- ply them to the scsi device. Return all status informa- tion and return data to the process. The ioctl will re- turn a successful status even if the device rejected the command. As all status is returned to the user, it is up to the user process to examine this information to decide the success of the command. SCIOCREPROBE Ask the system to probe the scsi busses for any new dev- ices. If it finds any, they will be attached to the ap- propriate drivers. The search can be narrowed to a specific bus, target or lun. The new device may or may not be related to the device on which the ioctl was per- formed. SCIOCIDENTIFY Ask the driver what its bus, target and lun are. In addi- tion, the device type, ATAPI or SCSI, is returned. SCIOCDECONFIG Ask the device to disappear. This may not happen if the device is in use.
The system allows common device drivers to work through many different types of adapters. The adapters take requests from the upper layers and do all IO between the SCSI bus and the system. The maximum size of a transfer is governed by the adapter. Most adapters can transfer 64KB in a single operation, and many can transfer larger amounts.
Some adapters support target mode in which the system is capable of operating as a device, responding to operations initiated by another sys- tem. Target mode will be supported for some adapters, but is not yet com- plete for this version of the scsi system.
When the kernel is compiled with option SCSIDEBUG, the SCIOCDEBUG ioctl can be used to enable various amounts of tracing information on any specific device. Devices not being traced will not produce trace informa- tion. The four bits that make up the debug level each control certain types of debugging information. Bit 0 shows all scsi bus operations including scsi commands, error in- formation and the first 48 bytes of any data transferred. Bit 1 shows routines called. Bit 2 shows information about what branches are taken and often some of the return values of functions. Bit 3 shows more detailed information including DMA scatter-gather logs.
aac(4), adv(4), adw(4), aha(4), ahb(4), ahc(4), aic(4), ami(4), asc(4), atapiscsi(4), bha(4), cac(4), cd(4), ch(4), dpt(4), esp(4), gdt(4), iha(4), intro(4), ioprbs(4), iopsp(4), isp(4), mpt(4), ncr(4), ncrscsi(4), oosiop(4), osiop(4), pcscp(4), sd(4), sea(4), ses(4), si(4), siop(4), ss(4), ssh(4), st(4), sw(4), trm(4), twe(4), uk(4), umass(4), usscanner(4), vs(4), wds(4), wdsc(4), scsi(8)
This scsi system appeared in MACH 2.5 at TRW. MirOS BSD #10-current March 12, 2004 2
Generated on 2015-07-19 22:36:15 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.