RT(4) BSD Programmer's Manual RT(4)
rt - AIMS Lab Radiotrack FM radio device driver
rt0 at isa? port 0x30c rt1 at isa? port 0x20c rt* at isapnp? radio* at rt?
The rt driver provides support for the AIMS Lab Radiotrack FM radio tuners and compatible - RadioReveal RA300 FM radio tuners and tuners at SoundForte RadioX SF16-FMI (Creative ViBRA16C PnP). The Radiotrack is a stereo FM tuner that can tune in the range 87.5 - 108.0 MHz, report signal status on the current frequency, and force audio output to mono. The card is based on the LM7000 chip; see radio(4) for details. The Radiotrack cards take only one I/O port. The I/O port is set by the driver to the value specified in the configuration file and must be ei- ther 0x20c or 0x30c.
intro(4), isa(4), isapnp(4), radio(4), radio(9)
The rt device driver appeared in OpenBSD 3.0.
The rt driver was written by Vladimir Popov <firstname.lastname@example.org> and Maxim Tsyplakov <email@example.com>. The man page was written by Vladimir Popov <firstname.lastname@example.org>.
Support for the SF16-FMI cards is rather ugly, the driver can not deter- mine signal state and force audio output to mono. It is impossible to determine which frequency the card is tuned to. Thus, the driver will report an internally stored value even if it is not correct (e.g. tuning was done through the direct I/O access). MirOS BSD #10-current October 8, 2001 1
Generated on 2015-04-13 10:26:13 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.