PNINEK(4) BSD Programmer's Manual (SPARC) PNINEK(4)
pninek - Weitek Power9000 accelerated frame buffer
btcham0 at obio? pninek0 at sbus? slot ? offset ? wsdisplay* at pninek?
The pninek is a color frame buffer with graphics acceleration, embedded in the Tadpole SPARCbook 3 laptop. It is based on the Weitek Power9000 video processor and a Brooktree Bt445 'Chameleon' RAMDAC. Due to specifics of the video hardware on the Tadpole SPARCbook 3, the complete driver is split in two parts: btcham RAMDAC interface pninek Video controller interface The combination of both btcham and pninek drivers interfaces the frame buffer with the wscons(4) console framework. They do not provide direct device driver entry points but make their function available via the internal wsdisplay(4) interface. If the tctrl(4) device is also configured, the pninek will be powered down when the lid of the laptop is closed or the screen is blanked.
agten(4), bwtwo(4), cgeight(4), cgfour(4), cgfourteen(4), cgsix(4), cgthree(4), cgtwelve(4), cgtwo(4), intro(4), mgx(4), pnozz(4), rfx(4), sbus(4), tctrl(4), tcx(4), tvtwo(4), vigra(4), wscons(4), wsdisplay(4), zx(4)
There is currently no way to switch back and forth from the onboard display to the external connector. It is not possible to change resolu- tions. MirOS BSD #10-current June 16, 2003 1
Generated on 2013-09-18 04:33:42 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.