PCMCIA(4) BSD Programmer's Manual PCMCIA(4)
pcmcia - introduction to PCMCIA (PC Card) support
# i386 pcic0 at isa? port 0x3e0 iomem 0xd0000 iosiz 0x10000 pcic1 at isa? port 0x3e2 iomem 0xe0000 iosiz 0x4000 pcic2 at isa? port 0x3e4 iomem 0xe0000 iosiz 0x4000 pcic* at isapnp? pcic* at pci? dev? function ? pcmcia* at pcic? controller ? socket ? # i386 tcic0 at isa? port 0x240 iomem 0xd0000 iosiz 0x10000 pcmcia* at tcic? controller ? socket ? # sparc tslot* at sbus? slot ? offset ? pcmcia* at tslot? socket ? # sparc/sparc64 stp* at sbus? slot ? offset ? pcmcia* at stp? socket ? # all architectures cbb* at pci? dev? function ? cardslot* at cbb? flags 0x0000 pcmcia* at cardslot?
The pcmcia subsystem provides machine-independent bus support and drivers for PCMCIA (PC Card) devices.
The following devices are supported, sorted by function and driver name:
gpr(4) GemPlus GPR400 smartcard reader.
com(4), pccom(4) 8250/16450/16550-compatible PCMCIA serial cards and modems.
an(4) Aironet Communications 4500/4800 IEEE 802.11DS wireless controll- er. awi(4) BayStack 650 wireless 802.11FH wireless controller. cnw(4) Xircom Creditcard Netwave cards. ep(4) 3Com 3c556, 3c562, 3c574, and 3c589 EtherLink III Ethernet cards. ne(4) NE2000 compatible cards. ray(4) Raytheon Raylink / WebGear Aviator IEEE 802.11FH 2Mbps wireless controller. rln(4) Proxim RangeLAN2 PC-Card. sm(4) Megahertz Ethernet cards. wi(4) WaveLAN/IEEE, PRISM-II and Spectrum24 IEEE 802.11DS cards. xe(4) Xircom 16bit Ethernet cards.
aic(4) Adaptec APA-140 and NewMedia BusToaster SCSI controller cards.
wdc(4) Devices which implement an ATA/IDE interface, such as mini disk drives, CDROMs. This includes Compact Flash cards which emulate a disk drive. The supported PCMCIA controllers are those that are i82365 compatible.
On some pcmcia adapters, for instance the sbus(4)-based stp(4), the pcmcia bus will be mapped in big-endian format instead of the natural (and preferred) little endian format. Unfortunately such controllers lack the hardware facility to swap bytes, and it is not efficient to convert all drivers to always know about this. While 8 bit drivers can invisibly work on such a bus, 16 bit drivers will need modification to handle this. So far, wi(4) is the only driver to require these modifications. If the pcmcia adapter is not detected, or if pcmcia events (such as card insertion) do not occur, there may be a PCI card BIOS mapped in the same memory space the pcmcia driver is configured to use (this is often the case with ethernet card boot ROMs). The output from dmesg(8) should con- tain a line beginning with "bios0" that lists the memory address and size of mapped regions. If there is a conflict, you can use boot_config(8) to change the iomem parameter of the pcic device to a non-overlapping ad- dress, such as 0xd8000 for pcic0. Some experimentation may be required to find a working value; in some cases the size parameter of the pcic device may need to be decreased to avoid a conflict.
aic(4), an(4), awi(4), cardbus(4), cbb(4), cnw(4), com(4), ep(4), gpr(4), intro(4), isa(4), isapnp(4), ne(4), pci(4), pcic(4), ray(4), rln(4), sbus(4), sm(4), stp(4), tcic(4), tslot(4), usb(4), wdc(4), wi(4), xe(4)
The pcmcia driver appeared in OpenBSD 2.3. MirOS BSD #10-current September 11, 1998 1
Generated on 2016-04-09 18:24:16 by $MirOS: src/scripts/roff2htm,v 1.83 2016/03/26 23:38:28 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2016 The MirOS Project, Germany.
This product includes material provided by mirabilos.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.