COM(4) BSD Programmer's Manual COM(4)
com, pccom - serial communications interface
# amd64 and i386 - pccom or com attachments pccom0 at isa? port 0x3f8 irq 4 pccom1 at isa? port 0x2f8 irq 3 pccom2 at isa? port 0x3e8 irq 5 pccom3 at isa? port 0x2e8 irq 9 pccom* at isapnp? pccom* at pcmcia? function ? pccom* at puc? port ? pccom* at addcom? slave ? pccom* at ast? slave ? pccom* at boca? slave ? pccom* at hsq? slave ? pccom* at rtfps? slave ? # alpha com0 at isa? port 0x3f8 irq 4 com1 at isa? port 0x2f8 irq 3 # hppa com0 at gsc? offset 0x5000 irq 5 com0 at gsc? offset 0x23000 irq 5 com1 at gsc? offset 0x22000 irq 6 com2 at gsc? offset ? irq 13 com1 at dino? irq 11 # sparc64 com* at asio? com* at ebus?
The com and pccom drivers provide support for NS8250-, NS16450-, NS16550-, ST16650-, and TI16750-based EIA RS-232C (CCITT V.28) communica- tions interfaces. The pccom driver (i386-only) also supports the XR16850 UART. The NS8250 and NS16450 have single character buffers, the NS16550 has a 16 character buffer, while the ST16650 has a 32 character buffer, and the TI16750 has a 64 character buffer. The XR16850 has a 128 character buffer. The com and pccom drivers are mutually exclusive; both may not be present in the same system at the same time. Attempting to compile such a system will fail. Input and output for each line may be set to one of following baud rates; 50, 75, 110, 134.5, 150, 300, 600, 1200, 1800, 2400, 4800, 9600, 19200, 38400, 57600, or 115200, or any other baud rate which is a factor of 115200.
/dev/tty00 /dev/tty01 /dev/cua00 /dev/cua01
com%d: %d silo overflows The input "silo" has overflowed and incoming data has been lost. com%d: weird interrupt: iir=%x The device has generated an unexpected interrupt with the code listed.
addcom(4), asio(4), ast(4), boca(4), dino(4), ebus(4), gsc(4), hsq(4), intro(4), isa(4), isapnp(4), pcmcia(4), puc(4), rtfps(4), tty(4)
The com driver was originally derived from the HP9000/300 dca driver.
Data loss is possible on busy systems with unbuffered UARTs at high speed. The name of this driver and the constants which define the locations of the various serial ports are holdovers from DOS. MirOS BSD #10-current July 12, 1998 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.