NGE(4) BSD Programmer's Manual NGE(4)
nge - National Semiconductor PCI gigabit ethernet adapter driver
nge* at pci? dev ? function ?
The nge driver provides support for various NICs based on the National Semiconductor DP83820 and DP83821 gigabit ethernet controller chips, in- cluding the following: • Addtron AEG320T • Ark PC SOHO-GA2500T (32-bit PCI) and SOHO-GA2000T (64-bit PCI) • Asante FriendlyNet GigaNIX 1000TA and 1000TPC • D-Link DGE-500T • LinkSys EG1032 (32-bit PCI) and EG1064 (64-bit PCI) • Netgear GA621 • Netgear GA622T • SMC EZ Card 1000 (SMC9462TX) • Surecom Technology EP-320G-TX • Trendware TEG-PCITX (32-bit PCI) and TEG-PCITX2 (64-bit PCI) All of these NICs are capable of 10, 100 and 1000Mbps speeds over CAT5 copper cable. The DP83820 supports TBI (ten bit interface) and GMII tran- sceivers, which means it can be used with either copper or 1000baseX fiber applications. The DP83820 supports ip(4), tcp(4), and udp(4) check- sum offload and VLAN tagging/insertion as well as a 2048-bit multicast hash filter and up to 4 pattern match buffers. Most cards also use the DP83861 10/100/1000 copper gigabit transceiver chip, which supports autonegotiation of 10, 100 and 1000Mbps modes in full or half duplex. The DP83820 also supports jumbo frames, which can be configured via the interface MTU setting. Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility configures the adapter to receive and transmit jumbo frames. Using jumbo frames can greatly improve performance for certain tasks, such as file transfers and data streaming. If the MTU is set to be larger than the NIC's transmit buffer (typically 8152 bytes), hardware output checksumming is disabled as the NIC cannot handle this case. The nge driver supports the following media types: autoselect Enable autoselection of the media type and options. The user can manually override the autoselected mode by adding media options to the appropriate hostname.if(5) file. 10baseT Set 10Mbps operation. The ifconfig(8) mediaopt option can also be used to select either full-duplex or half-duplex modes. 100baseTX Set 100Mbps (fast ethernet) operation. The ifconfig(8) mediaopt option can also be used to select either full- duplex or half-duplex modes. 1000baseT Set 1000baseT operation over twisted pair. full-duplex and half-duplex modes are supported. 1000baseSX Set 1000Mbps (gigabit ethernet) operation. Both full-duplex and half-duplex modes are supported. The nge driver supports the following media options: full-duplex Force full duplex operation. half-duplex Force half duplex operation. The nge driver also supports one special link option for 1000baseT cards: link0 With 1000baseT cards, establishing a link between two ports requires that one port be configured as a master and the other a slave. With autonegotiation, the master/slave set- tings will be chosen automatically. However when manually selecting the link state, it is necessary to force one side of the link to be a master and the other a slave. The nge driver configures the ports as slaves by default. Setting the link0 flag with ifconfig(8) will set a port as a master instead. For more information on configuring this device, see ifconfig(8).
nge%d: couldn't map memory A fatal initialization error has occurred. nge%d: couldn't map ports A fatal initialization error has occurred. nge%d: couldn't map interrupt A fatal initialization error has occurred. nge%d: no memory for softc struct! The driver failed to allocate memory for per-device instance information during initialization. nge%d: failed to enable memory mapping! The driver failed to initialize PCI shared memory mapping. This might happen if the card is not in a bus-master slot. nge%d: no memory for jumbo buffers! The driver failed to allocate memory for jumbo frames during initialization. nge%d: watchdog timeout The device has stopped responding to the net- work, or there is a problem with the network connection (cable).
arp(4), ifmedia(4), intro(4), netintro(4), nsgphy(4), pci(4), vlan(4), hostname.if(5), ifconfig(8) National Semiconductor DP83820 datasheet, http://www.national.com. National Semiconductor DP83861 datasheet, http://www.national.com.
The nge device driver first appeared in OpenBSD 3.0.
The nge driver was written by Bill Paul <firstname.lastname@example.org>. MirOS BSD #10-current May 11, 2001 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.