MPT(4) BSD Programmer's Manual MPT(4)
mpt - LSI Fusion-MPT SCSI and FibreChannel host adapter driver
mpt* at pci? dev ? function ? scsibus* at mpt?
The mpt driver provides support for the LSI Logic Fusion-MPT family of SCSI and Fibre Channel controllers: • 53c1020 (Single Ultra320 SCSI) • 53c1030 (Dual Ultra320 SCSI) • FC909 (1Gb/s Fibre Channel) • FC909A (Dual 1Gb/s Fibre Channel) • FC919 (2Gb/s Fibre Channel) • FC929 (Dual 2Gb/s Fibre Channel) • Emulated in VMWare ESX Server 2 The LSI Logic SCSI and Fibre Channel controllers contain firmware that presents a multiprotocol service layer based on the LSI Logic Fusion-MPT architecture. The firmware isolates the host drivers from the hardware and controls the device side of the message passing interface to the host device drivers. The firmware manages all phases of an I/O request and op- timizes the interrupt management for the system. For Fibre Channel, the firmware also manages all FC-2 through FC-4 services, which minimizes the amount of Fibre Channel unique services required with the host driver. The MPI (Message Passing Interface) defintion includes a register-level transport mechanism and a messaging protocol. A system doorbell and mes- sage queues define the MPI transport interface. Inbound Message Frames (MF), allocated in host memory, indentify I/O operations to be performed by the IO Controller (IOC). These operations are queued on the Request Queue by the host driver. Outbound Message Frames, also in host memory, track I/O operations as they complete. These frames are queued on the Re- ply Queue by the IOC. A doorbell mechanism is provided for IOC configura- tion, reset management, and IOC status.
cd(4), ch(4), intro(4), pci(4), scsi(4), sd(4), siop(4), st(4), uk(4)
The mpt driver first appeared in OpenBSD 3.5.
The driver was ported from NetBSD by Milos Urbanek, Kenneth R. Westerback and Marco Peereboom.
This driver does not function properly with MPT firmware levels higher than 1.03.00. The runtime MPT firmware is displayed under the REV heading for the 1020/1030 chips during POST. Example: HBA ID LUN VENDOR PRODUCT REV SYNC WIDE --- -- --- -------- ---------------- -------- ----- ---- 0 7 0 LSILogic 1020/1030[ 102] 1013D00 320.0 16 1 7 0 LSILogic 1020/1030[ 102] 1013D00 320.0 16 The version is 1013D00 which translates to 1.01.3D.00. The last two di- gits are normally not used and it is written in decimal notation. Thus making this example version 1.01.61. MirOS BSD #10-current February 25, 2004 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.