KUE(4) BSD Programmer's Manual KUE(4)
kue - Kawasaki LSI KL5KUSB101B USB Ethernet driver
kue* at uhub? port ?
The kue driver provides support for USB Ethernet adapters based on the Kawasaki LSI KL5KLUSB101B chipset. This includes the following adapters: 3Com 3c19250 3Com 3c460 HomeConnect AboCom Systems URE450 Ethernet ADS Technologies USB-10BT Aox USB101 ATen UC10T ATen DSB-650C Corega USB-T D-Link DSB-650C Entrega NET-USB-E45 I/O Data USB-ET/T Kingston Ethernet Kawasaki USB101 LinkSys USB10T Mobility Ethernet Netgear EA101 Peracom USB Portgear Ethernet Portsmith Express Ethernet Shark Pocket Adapter SMC 2102USB SMC 2104USB The KL5KLUSB101B supports a 128-entry multicast filter, single perfect filter entry for the station address and promiscuous mode. Packets are received and transmitted over separate USB bulk transfer endpoints. The Kawasaki adapter supports only 10Mbps half-duplex mode, hence there are no ifmedia(4) modes to select. For more information on configuring this device, see ifconfig(8).
kue%d: watchdog timeout A packet was queued for transmission and a transmit command was issued, however the device failed to acknowledge the transmission before a timeout expired. kue%d: no memory for rx list The driver failed to allocate an mbuf for the receiver ring.
arp(4), intro(4), netintro(4), usb(4), hostname.if(5), ifconfig(8)
The kue device driver first appeared in FreeBSD 4.0. OpenBSD support was added in OpenBSD 2.7.
The kue driver was written by Bill Paul <firstname.lastname@example.org> and port- ed to OpenBSD by Aaron Campbell <email@example.com>.
The kue driver does not accumulate Ethernet collisions statistics because the Kawasaki firmware does not appear to maintain any internal statis- tics. MirOS BSD #10-current January 4, 2000 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.