MEM(4) BSD Programmer's Manual (SPARC) MEM(4)
mem, kmem - memory files
The file /dev/mem is an interface to the physical memory of the computer. Byte offsets in this file are interpreted as physical memory addresses. Reading and writing this file is equivalent to reading and writing memory itself. An error will be returned if an attempt is made to reference an offset outside of /dev/mem. Kernel virtual memory is accessed via the file /dev/kmem in the same manner as /dev/mem. Only kernel virtual addresses that are currently mapped to memory are allowed.
On the SPARC, physical memory may be discontiguous; kernel virtual memory begins at 0xf8000000. Writeability of these devices is controlled by the system securelevel(7).
The /dev/mem and /dev/kmem files appeared in Version 6 AT&T UNIX. MirOS BSD #10-current June 5, 1993 1
Generated on 2013-09-18 04:33:42 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.