ISA(4) BSD Programmer's Manual ISA(4)
isa - introduction to ISA bus support
# amd64 and i386 isa0 at mainbus0 isa0 at pcib? # alpha isa* at pceb? isa* at sio? # cats isa0 at pcib? Attachments are machine-dependent and depend on the bus topology and ISA bus interface of your system. See intro(4) for your system for details.
The system includes a machine-independent ISA bus subsystem and several machine-independent ISA device drivers. Your system may support additional ISA devices. Drivers for ISA devices not listed here are machine-dependent. Consult your system's intro(4) for additional information. Note that interrupt mappings on the i386 may require that you configure your BIOS to reserve the interrupts for these devices as "Legacy ISA". If such configuration is not done, the system may use those interrupts for pci(4) or isapnp(4) devices instead.
At least the following devices are supported:
aha(4) Adaptec AHA-154x family (154xA, 154xB, 154xC, and 154xCF) and the BusLogic BT54x SCSI interfaces. aic(4) Adaptec AIC-6260 and Adaptec AIC-6360 based SCSI interfaces, in- cluding the Adaptec 152x, SoundBlaster SCSI interfaces, and a variety of compatibles. bha(4) BusLogic BT-445 SCSI interfaces. dpt(4) DPT SmartCache/SmartRAID III and IV SCSI interfaces. sea(4) Seagate/Future Domain SCSI cards. ST01/02, Future Domain TMC-885, and Future Domain TMC-950. uha(4) Ultrastor 14f SCSI interfaces. wds(4) WD-7000 family of bus-mastering SCSI interfaces.
mcd(4) Mitsumi CD-ROM drives. wdc(4) Standard Western Digital type hard drive controllers: MFM, RLL, ESDI, and IDE/ATAPI. See also the pciide(4) device driver which is used instead on machines with PCI IDE controllers. wt(4) Wangtek and compatible QIC-02 and QIC-36 tape drives.
com(4), pccom(4) NS8250, NS16450, NS16550, ST16550, and TI16750 serial driver. The pccom(4) driver is used on the i386; all the rest use com(4). addcom(4) Addonics FlexPort 8S serial communication cards. ast(4) Multi-port serial communications card first made by AST. boca(4) Boca BB100 and BB2016 multiplexing serial communications cards. cy(4) Cyclades Cyclom-4Y, -8Y, and -16Y asynchronous serial communica- tions cards. lpt(4) Standard ISA parallel port interface. rtfps(4) IBM RT four-port serial cards.
ec(4) 3Com EtherLink II (3c503) Ethernet interfaces. ef(4) 3Com Fast EtherLink III (3c515) Ethernet interfaces. eg(4) 3Com EtherLink Plus (3c505) Ethernet interfaces. el(4) 3Com EtherLink (3c501) Ethernet interfaces. ep(4) 3Com EtherLink III (3c509) Ethernet interfaces. ie(4) Ethernet interfaces based on Intel 82586 Ethernet chip, including AT&T Starlan-10, AT&T EN100, AT&T Starlan Fibre, and 3Com 3c507. lc(4) DEC EtherWORKS III (DE203, DE204 & DE205) Ethernet interfaces. le(4) Ethernet interfaces based on the AMD LANCE chip, including BICC Isolan, Novell NE2100, Digital DEPCA, and PCnet-ISA. ne(4) Novel NE2000 and compatible Ethernet interfaces. sm(4) SMC91C9x-based Ethernet interfaces. we(4) Western Digital/SMC 80x3, SMC Elite Ultra, and SMC EtherEZ Ethernet interfaces.
aria(4) Sierra's Aria based sound cards. ess(4) ESS Technology AudioDrive 1788-, 1888-, 1887-, and 888-based sound cards. gus(4) Gravis Ultrasound sound cards. pas(4) ProAudio Spectrum sound cards. pss(4) Personal Sound System-compatible sound cards, including Cardinal Digital SoundPro 16 and Orchid Soundwave 32. sb(4) Soundblaster, Soundblaster 16, and Soundblaster Pro sound cards. wss(4) Windows Sound System-compatible sound cards based on the AD1848 and compatible chips. mpu(4) Roland/Yamaha generic MIDI UART devices.
az(4) Aztech/PackardBell radio card devices. rt(4) AIMS Lab Radiotrack FM radio device devices. rtii(4) AIMS Lab Radiotrack II FM radio device devices. sfr(4) SoundForte RadioLink SF16-FMR FM radio devices. sf2r(4) SoundForte RadioLink SF16-FMR2 FM radio devices.
it(4) ITE IT8705F, IT8712F and SiS SiS950 hardware monitors. lm(4) National Semiconductor LM78, LM79 and compatible hardware moni- tors. pcic(4) ISA PCMCIA controllers. Note that some ISA devices also have newer ISA Plug-and-Play variants. These are listed in isapnp(4).
addcom(4), aha(4), aic(4), aria(4), ast(4), az(4), bha(4), boca(4), cardbus(4), com(4), cy(4), dpt(4), ec(4), ef(4), eg(4), el(4), ep(4), ess(4), gus(4), ie(4), intro(4), isapnp(4), it(4), lc(4), le(4), lm(4), lpt(4), mcd(4), ne(4), pci(4), pcib(4), pcic(4), pcmcia(4), pss(4), rt(4), rtfps(4), rtii(4), sb(4), sea(4), sf2r(4), sfr(4), sm(4), uha(4), usb(4), wdc(4), we(4), wss(4), wt(4)
The machine-independent ISA subsystem appeared in OpenBSD 2.0. MirOS BSD #10-current April 4, 2000 2
Generated on 2015-10-25 00:47:46 by $MirOS: src/scripts/roff2htm,v 1.81 2015/10/16 13:19:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by mirabilos.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.