INTRO(4) BSD Programmer's Manual (SPARC) INTRO(4)
intro - introduction to special files and hardware support
The manual pages in section 4 describe the special files, related driver functions, and networking support available in the system. In this part of the manual, the SYNOPSIS section of each configurable device gives a sample specification for use in constructing a system description for the config(8) program. The DIAGNOSTICS section lists messages which may ap- pear on the console and/or in the system error log /var/log/messages due to errors in device operation; see syslogd(8) for more information. This section contains both devices which may be configured into the sys- tem and network related information. The networking support is introduced in netintro(4).
This section describes the hardware supported on the SPARC platform. Software support for these devices comes in two forms. A hardware device may be supported with a character or block device driver, or it may be used within the networking subsystem and have a network interface driver. Block and character devices are accessed through files in the file system of a special type; see mknod(8). Network interfaces are indirectly ac- cessed through the interprocess communication facilities provided by the system; see socket(2). A hardware device is identified to the system at configuration time and the appropriate device or network interface driver is then compiled into the system. When the resultant system is booted, the autoconfiguration facilities in the system probe for the device and, if found, enable the software support for it. If a device does not respond at autoconfigura- tion time it is not accessible at any time afterwards. To enable a device which did not autoconfigure, the system will have to be rebooted. The autoconfiguration system is described in autoconf(4). A list of the supported devices is given below.
The devices listed below are supported in this incarnation of the system. Pseudo-devices are not listed. Devices are indicated by their functional interface. Not all supported devices are listed. agten(4) Fujitsu AG-10e frame buffer. audioamd(4) AMD 79C30 obio (sun4c and SPARC Classic) audio controller. audiocs(4) CS4231 based audio found in some sun4c and sun4m models. be(4) 10BaseT/100BaseTX SBus Ethernet controller. bwtwo(4) Black and white SBus and obio (sun4) frame buffer. cgeight(4) 24 bit VMEbus color frame buffer. cgfour(4) 8 bit obio (sun4 P4 bus) color graphics frame buffer. cgfourteen(4) 24 bit MBus color frame buffer. cgsix(4) 8 bit SBus and obio (sun4c & sun4m) color graph- ics frame buffer. cgthree(4) 8 bit VMEbus, SBus, and obio (sun4m) color graphics frame buffer. cgtwelve(4) 24 bit SBus color frame buffer. cgtwo(4) 8 bit VMEbus color frame buffer. daadio(4) MATRIX MD-DAADIO digital/analog and analog/digital parallel i/o board. esp(4) NCR53C90 ESP100 (Sun 4/300), ESP100A (sun4c), ESP200 (sun4m) SCSI controller, FSBE/S (X1053A, part # 501-2015) Fast SCSI- 2/Buffered Ethernet SBus controller. fd(4) Intel 82072 obio (sun4c) or Intel 82077 obio (sun4m) floppy disk drive controller. fga(4) Force FGA5000 SBus/VME bridge. hme(4) SBus HME Ethernet controllers (SunSwift) and SBus QuadFastEthernet controllers. ie(4) Intel 82586 Ethernet controller (Sun 4/100 and 4/200). isp(4) Qlogic ISP SBus SCSI controller. le/lebuffer(4) AMD 7990 LANCE ethernet controller (Sun 4/300, sun4c, sun4m, SBus). led(4) Diagnostic LED display on sun4 and sun4m (4/600) machines. magma(4) Magma serial/parallel communication boards. mgx(4) Southland Media Systems MGX and MGXPlus frame buffers. openprom(4) Sun Open boot PROM (what became IEEE 1275) con- figuration driver. pninek(4) Weitek Power9000 frame buffer found on Tadpole SPARCbook 3. pnozz(4) Weitek Power9100 frame buffer found on Tadpole SPARCbook 3GS, 3GX, 3TX and 3XP. presto(4) Prestoserve NVRAM. rfx(4) Vitec/Connectware/AP&D RasterFlex framebuffer series. qe(4) Quad 10BaseT SBus Ethernet controller. qec(4) Supported as a carrier for the be or qe Ethernet controllers. scf(4) Force CPU-5 system configuration registers. si(4) NCR5380 "SCSI-2" VMEbus (Sun 4/200, Sun 4/400) SCSI controller. spif(4) Sun SUNW,spif serial/parallel communication boards. sw(4) NCR5380 obio (Sun 4/100) "SCSI Weird" SCSI con- troller. tctrl(4) Tadpole microcontroller interface. tcx(4) 8 or 24 bit SBus color graphics frame buffer. tvtwo(4) Parallax XVideo and PowerVideo 24 bit SBus color frame buffer. vigra(4) 8 bit SBus color framebuffer with VGA-compatible modes and connector. xbox(4) SBus Expansion Subsystem. xd(4) Xylogics 753/7053 VMEbus SMD disk controller. xy(4) Xylogics 450/451 VMEbus SMD disk controller. zs/zstty/zskbd(4) Zilog 8530 serial controller (and serial key- boards). zx(4) 24 bit accelerated SBus color frame buffer.
The sparc intro first appeared in OpenBSD 2.3. MirOS BSD #10-current February 29, 2004 1
Generated on 2013-09-18 04:33:42 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.