HSQ(4) BSD Programmer's Manual HSQ(4)
hsq - multiplexing serial communications interface
hsq0 at isa? port 0x140 irq 10 com* at hsq? slave ? or pccom* at hsq? slave ?
The hsq driver provides support for Hostess (Comtrol Corporation, www.comtrol.com) and compatible boards that multiplex together up to four EIA RS-232C (CCITT V.28) communications interfaces. Each hsq device is the master device for up to four com devices. The ker- nel configuration specifies these com devices as slave devices of the hsq device, as shown in SYNOPSIS. The slave ID given for each com device determines which bit in the interrupt multiplexing register is tested to find interrupts for that device. The port specification for the hsq dev- ice is used to compute the base addresses for the com subdevices (they are equal to port + ID * 8) and the port for the interrupt multiplexing register (it is equal to port + 7). More technical details on how the driver works can be found in the big comment at the beginning of the driver's source code. Information on setup of card's configuration switches should be taken from Comtrol Corporation's web site, since the author wrote and tested the driver only with Hostess-compatible cards.
com(4), intro(4), isa(4)
The hsq driver was written by Denis A. Doroshenko based on the ast(4) driver. MirOS BSD #10-current March 30, 1994 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.