GRE(4) BSD Programmer's Manual GRE(4)
gre - encapsulating network device
pseudo-device gre [count]
GRE, WCCPv1, and MobileIP are enabled with the following sysctl(3) vari- ables respectively in /etc/sysctl.conf: net.inet.gre.allow Allow GRE packets in and out of the system. net.inet.gre.wccp Allow WCCPv1-style GRE packets into the system (depends on the above). net.inet.mobileip.allow Allow MobileIP packets in and out of the system.
The gre network interface allows tunnel construction using the Cisco GRE or the Mobile-IP (RFC 2004) encapsulation protocols. A gre interface can be created at runtime using the ifconfig greN create command or by setting up a hostname.if(5) configuration file for netstart(8). This driver currently supports the following modes of operation: GRE encapsulation (IP protocol number 47). Encapsulated datagrams are prepended by an outer datagram and a GRE header. The GRE header specifies the type of the encapsulated da- tagram and thus allows for tunneling other protocols than IP like e.g. AppleTalk. GRE mode is the default tunnel mode on Cisco routers. This is also the default mode of operation of the greX in- terfaces. MOBILE encapsulation (IP protocol number 55). Datagrams are encapsulated into IP, but with a much smaller encapsu- lation header. This protocol only supports IP in IP encapsulation, and is intended for use with mobile IP. The network interfaces are named gre0, gre1, etc. The number of inter- faces is given by the corresponding pseudo-device line in the system con- fig file. gre interfaces support the following ioctl(2)s: GRESADDRS: Set the IP address of the local tunnel end. GRESADDRD: Set the IP address of the remote tunnel end. GREGADDRS: Query the IP address that is set for the local tunnel end. GREGADDRD: Query the IP address that is set for the remote tunnel end. GRESPROTO: Set the operation mode to the specified IP protocol value. The pro- tocol is passed to the interface in (struct ifreq)->ifr_flags. The operation mode can also be given as link0 IPPROTO_GRE -link0 IPPROTO_MOBILE GREGPROTO: Query operation mode. Note that the IP addresses of the tunnel endpoints may be the same as the ones defined with ifconfig(8) for the interface (as if IP is encapsulat- ed), but need not be, as e.g. when encapsulating AppleTalk.
Configuration example: Host X-- Host A ----------------tunnel---------- Cisco D------Host E \ | \ / +------Host B----------Host C----------+ On Host A (OpenBSD): # route add default B # ifconfig greN create # ifconfig greN A D netmask 0xffffffff linkX up # ifconfig greN tunnel A D # route add E D On Host D (Cisco): Interface TunnelX ip unnumbered D ! e.g. address from Ethernet interface tunnel source D ! e.g. address from Ethernet interface tunnel destination A ip route C <some interface and mask> ip route A mask C ip route X mask tunnelX OR On Host D (OpenBSD): # route add default C # ifconfig greN create # ifconfig greN D A # ifconfig greN tunnel D A To reach Host A over the tunnel (from host D), there has to be an alias on Host A for the Ethernet interface: ifconfig <etherif> alias Y and on the Cisco ip route Y mask tunnelX
For correct operation, the gre device needs a route to the destination, that is less specific than the one over the tunnel. (There needs to be a route to the decapsulating host that does not run over the tunnel, as this would create a loop.) In order for ifconfig(8) to actually mark the interface as up, the key- word ``up'' must be given last on its command line. The kernel must be set to forward datagrams by issuing the appropriate option to sysctl(8). The GRE interface will accept WCCPv1-style GRE encapsulated packets from a Cisco router. Some magic with the packet filter configuration and a caching proxy like squid are needed to do anything useful with these packets.
atalk(4), inet(4), ip(4), netintro(4), options(4), protocols(5), ifconfig(8), sysctl(8) A description of GRE encapsulation can be found in RFC 1701, RFC 1702. A description of MOBILE encapsulation can be found in RFC 2004. A description of WCCPv1 can be found in draft-ietf-wrec-web-pro-00.txt, and WCCPv2 in draft-wilson-wrec-wccp-v2-00.txt. Both of these documents can be found at http://www.wrec.org/ (at the time of this writing).
Heiko W.Rupp <firstname.lastname@example.org>
The compute_route() code in net/if_gre.c toggles the last bit of the IP- address to provoke the search for a less specific route than the one directly over the tunnel to prevent loops. This is possibly not the best solution. To avoid the address munging described above, turn on the link1 flag on the ifconfig command line. This implies that the GRE packet destination and the remote host are not the same IP addresses, and that the GRE des- tination does not route over the greX interface itself. GRE RFC not yet fully implemented (no GRE options). For the WCCP GRE encapsulated packets we can only reliably accept WCCPv1 format; WCCPv2 formatted packets add another header which will skew the decode, and results are not defined (i.e. don't do WCCPv2). MirOS BSD #10-current September 13, 1998 2
Generated on 2013-04-27 00:20:00 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.