ESS(4) BSD Programmer's Manual ESS(4)
ess - ESS Technology AudioDrive family audio device driver
ess* at isapnp? audio* at ess?
The ess driver provides support for the ESS 1788, 1888, 1887, and 888 Au- dioDrive audio devices. The AudioDrive 1788 is a half-duplex device, while the 1888, 1887, and 888 are full-duplex. All are capable of 8- and 16-bit audio sample recording and playback at rates up to 44.1kHz. The AudioDrive takes 16 I/O ports. The I/O port range, IRQ, and DRQ chan- nels are set by the driver to the values specified in the configuration file (or for isapnp or ofisa, the values assigned from the firmware). The I/O port base must be one of 0x220, 0x230, 0x240, 0x250. The IRQ must be one of 5, 7, 9, 10 (or 15 on the 1887 only). The first DRQ channel must be selected from 0, 1, 3. The second DRQ channel (used for playback by the full-duplex 1888/1887, ignored by the 1788) can additionally be set to 5. If both DRQ channels are used they must be different. The joystick interface (if enabled) is handled by the joy(4) driver.
audio(4), intro(4), isapnp(4), joy(4), sb(4)
The ess device driver appeared in OpenBSD 2.2.
The AudioDrive devices have a SoundBlaster compatibility mode, and may be detected by the SoundBlaster driver (see sb(4)) rather than the Au- dioDrive driver. The workaround is to remove or disable the SoundBlaster driver from the kernel configuration. MirOS BSD #10-current August 5, 1999 1
Generated on 2015-10-25 00:47:46 by $MirOS: src/scripts/roff2htm,v 1.81 2015/10/16 13:19:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by mirabilos.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.