CH(4) BSD Programmer's Manual CH(4)
ch - scsi media-changer (juke box) driver
ch? at scsibus? target ? lun ?
The ch driver provides support for SCSI juke boxes. It allows many slots of media to be multiplexed between a number of drives. A SCSI adapter and a logical scsibus must also be separately configured into the system before a SCSI changer can be configured. As the SCSI adapter is probed during boot, the SCSI bus is scanned for devices. Any devices found which answer as "Changer" type devices will be "attached" to the ch driver. The first device found will be attached as ch0 and the next ch1, etc. It is also possible to specify what ch unit a device should come on-line as; refer to scsi(4) for details on kernel configuration.
In configuring, if an optional count is given in the specification, that number of SCSI media changers are configured. Most storage for them is allocated only when found so a large number of configured devices is cheap (once the first has included the driver).
The following ioctl(2) call applies to the changer. It is defined in the header file <sys/chio.h>. CHIOOP This appears to be a "do-everything" call.
/dev/ch[0-9] device entries
cd(4), intro(4), scsi(4), sd(4), st(4)
These manpages were derived from the FreeBSD documentation of the generic SCSI drivers. Since naming and calling conventions may have diverged or suffered port specific changes, please review the appropriate header files and configuration file for your port.
The ch driver appeared in 386BSD 0.1. MirOS BSD #10-current March 28, 1997 1
Generated on 2013-04-27 00:20:00 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.