CGTHREE(4) BSD Programmer's Manual (SPARC) CGTHREE(4)
cgthree - 8-bit color frame buffer
cgthree* at sbus? slot ? offset ? cgthree* at obio0 slot ? offset ? (some sun4m models) wsdisplay* at cgthree?
The cgthree is a color frame buffer, available as an SBus card or on- board on some sun4c and sun4m workstations. A small number of frame buffer SBus cards, not manufactured by Sun, are cgthree-compatible and will also be recognized by the cgthree driver. The cgthree driver interfaces the frame buffer with the wscons(4) console framework. It does not provide direct device driver entry points but makes its functions available via the internal wsdisplay(4) interface.
If the cgthree frame buffer is used as the console display, it is possi- ble, for some models, to select a different resolution than the default 1152x900 or 1024x768 by changing the OpenPROM environment. To change the default resolution, type the following: ok setenv output-device screen:r1152x900x66 to change to a 66Hz 1152x900 resolution. If the cgthree frame buffer is a secondary display, or a serial console is used, the display resolution can not be changed without using an nvramrc OpenPROM script. Refer to the Sun Frame Buffer FAQ for details. The cgthree frame buffer accepts the following resolutions: screen:r1024x768x77 Super VGA 1024x768, with a refresh rate of 77Hz. This is the default setting on model 501-2691. screen:r1152x900x66 Standard 1152x900, with a refresh rate of 66Hz. This is the default setting on older models (501- 1415 and 501-8044). screen:r1152x900x76 Standard 1152x900, with a refresh rate of 76Hz. This is the default setting on more recent models (501-1718 and 501-1909). Note that not all models support settings other than their default set- ting.
These frame buffers are cgthree-compatible cards with a VGA-compatible video connector. There are only two resolutions supported, selected by jumper JP2 on the card: JP2 Resolution open 1024x768, 60Hz short 1152x900, 66Hz
agten(4), bwtwo(4), cgeight(4), cgfour(4), cgfourteen(4), cgsix(4), cgtwelve(4), cgtwo(4), intro(4), mgx(4), pninek(4), pnozz(4), rfx(4), sbus(4), tcx(4), tvtwo(4), vigra(4), wscons(4), wsdisplay(4), zx(4) Sun Frame Buffer FAQ, http://www.sunhelp.org/faq/FrameBuffer.html. MirOS BSD #10-current April 28, 2003 1
Generated on 2013-09-18 04:33:42 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.