CGFOURTEEN(4) BSD Programmer's Manual (SPARC) CGFOURTEEN(4)
cgfourteen - accelerated 8/24-bit color frame buffer
cgfourteen0 at obio0 addr 0x9c000000 (SS10SX and SS20) cgfourteen1 at obio0 addr 0x90000000 (SS10SX and SS20) wsdisplay* at cgfourteen?
The cgfourteen is the on-board color frame buffer, with graphics ac- celeration and overlay capabilities, found on the SPARCstation 10SX and SPARCstation 20 workstations. The frame buffer will not be enabled unless a VSIMM memory module is installed. The second frame buffer will also require an 'Auxiliary Video Board' to be installed. The cgfourteen driver interfaces the frame buffer with the wscons(4) con- sole framework. It does not provide direct device driver entry points but makes its functions available via the internal wsdisplay(4) interface.
If the cgfourteen frame buffer is used as the console display, a dif- ferent resolution than the default 1152x900 can be selected by changing the OpenPROM environment. To change the default resolution, type the fol- lowing: ok setenv output-device screen:r1280x1024x76 to change to a 76Hz 1280x1024 resolution. If the cgfourteen frame buffer is a secondary display, or a serial con- sole is used, the display resolution can not be changed without using an nvramrc OpenPROM script. Refer to the Sun Frame Buffer FAQ for details. The cgfourteen frame buffer accepts the following resolutions:
screen:r1152x900x66 Standard 1152x900, with a refresh rate of 66Hz. screen:r1152x900x76 Standard 1152x900, with a refresh rate of 76Hz. This is the default setting. screen:r1280x1024x66 High res 1280x1024, with a refresh rate of 66Hz.
The following video modes are supported by the hardware, but not by Sun. screen:r1024x768x60 Super VGA 1024x768, with a refresh rate of 60Hz. screen:r1024x768x66 Super VGA 1024x768, with a refresh rate of 60Hz. screen:r1024x768x70 Super VGA 1024x768, with a refresh rate of 70Hz. screen:r1024x800x84 1024x800, with refresh rate of 84Hz. screen:r1280x1024x76m High res 1280x1024, with a refresh rate of 76Hz. There is no typo, the 'm' suffix is required. screen:r1600x1280x66 High res 1600x1280, with a refresh rate of 66Hz. screen:r1920x1080x72 1920x1080, with a refresh rate of 72Hz. Resolutions of 1280x1024, 1600x1280 and 1920x1080 are 8-bit only with 4MB VSIMM.
agten(4), bwtwo(4), cgeight(4), cgfour(4), cgsix(4), cgthree(4), cgtwelve(4), cgtwo(4), intro(4), mgx(4), pninek(4), pnozz(4), rfx(4), tcx(4), tvtwo(4), vigra(4), wscons(4), wsdisplay(4), zx(4) Sun Frame Buffer FAQ, http://www.sunhelp.org/faq/FrameBuffer.html. MirOS BSD #10-current April 6, 2003 1
Generated on 2012-09-10 15:20:00 by $MirOS: src/scripts/roff2htm,v 1.73 2012/07/01 16:04:30 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2011 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.