BOCA(4) BSD Programmer's Manual BOCA(4)
boca - multiplexing serial communications interface
For 4-port BB1004 boards and 8-port BB1008 boards: boca0 at isa? port 0x100 irq 5 com* at boca? slave ? or pccom* at boca? slave ? For 16-port BB2016 boards: boca0 at isa? port 0x100 irq 5 boca1 at isa? port 0x140 irq 5 com* at boca? slave ? or pccom* at boca? slave ? (The BB2016 is functionally equivalent to two BB1008 boards, and is con- figured as such.)
The boca driver provides support for BOCA Research BB1004, BB1008, and BB2016 boards that multiplex together up to four, eight, or sixteen EIA RS-232C (CCITT V.28) communications interfaces. Each boca device is the master device for up to eight com devices. The kernel configuration specifies these com devices as slave devices of the boca device, as shown in SYNOPSIS. The slave ID given for each com device determines which bit in the interrupt multiplexing register is tested to find interrupts for that device. The port specification for the boca dev- ice is used to compute the base addresses for the com subdevices and the port for the interrupt multiplexing register.
com(4), intro(4), isa(4)
The boca driver was written by Charles Hannum, based on the ast driver and source code from David Muir Sharnoff. David wishes to acknowledge the assistance of Jason Venner in determining how to use the BOCA boards. MirOS BSD #10-current January 3, 1995 1
Generated on 2013-10-31 22:57:03 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.