AXE(4) BSD Programmer's Manual AXE(4)
axe - ASIX Electronics AX88172 USB Ethernet driver
axe* at uhub? port ? ukphy* at mii?
The axe driver provides support for USB Ethernet adapters based on the ASIX Electronics AX88172 USB 2.0 chipset, including the following: • D-Link DUBE100 • LinkSys USB200M • Netgear FA120 • Buffalo(MELCO) LUA-U2-KTX The AX88172 is a USB 2.0 device which contains a 10/100 Ethernet MAC with MII interface and is designed to work with both Ethernet and HomePNA transceivers. The AX88172 will operate with both USB 1.x and USB 2.0 con- trollers, however performance with 1.x controllers will be limited since the USB 1.x standard specifies a maximum transfer speed of 12Mbps. Users with USB 1.x controllers should therefore not expect to actually achieve 100Mbps speeds with these devices. The AX88172 supports a 64-bit multicast hash table, single perfect filter entry for the station address, all-multicast mode, and promiscuous mode. Packets are received and transmitted over separate USB bulk transfer end- points. The axe driver supports the following media types: autoselect Enable autoselection of the media type and options (this is the default). The user can manually override the autoselected mode by adding media options to the appropriate hostname.if(5) file. 10baseT Set 10Mbps operation. 100baseTX Set 100Mbps (fast Ethernet) operation. The driver supports the following media options: full-duplex Force full-duplex operation. half-duplex Force half-duplex operation. The interface will operate in half-duplex mode if no media option is specified. For more information on configuring this device, see ifconfig(8).
axe%d: watchdog timeout A packet was queued for transmission and a transmit command was issued, however the device failed to acknowledge the transmission before a timeout expired. axe%d: no memory for rx list The driver failed to allocate an mbuf for the receiver ring.
arp(4), ifmedia(4), intro(4), netintro(4), usb(4), hostname.if(5), ifconfig(8) ASIX AX88172 data sheet, http://www.asix.com.tw.
The axe device driver first appeared in OpenBSD 3.6.
The axe driver was written by Bill Paul <email@example.com> and ported to OpenBSD by Greg Taleck <firstname.lastname@example.org>. MirOS BSD #10-current April 20, 2003 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.