AWI(4) BSD Programmer's Manual AWI(4)
awi - BayStack 650 IEEE 802.11FH PCMCIA wireless network driver
awi* at pcmcia? function ?
The awi driver provides support for wireless adapters based upon the AMD 802.11 PCnet Mobile firmware. This includes the following adapters: Bay Networks BayStack 650 Bay Networks BayStack 660 Bay Network AirSurfer Pro AMD Am79C930 Icom SL-200 Nokia C020 Farallon Communications SkyLINE Wireless Zoom Air-4000 The PCnet Mobile design is based on an AMD 79c930 controller, which pro- vides access to 32kb of memory shared between the controller and the host. All host/device interaction is via this shared memory, which can be accessed either via PCMCIA memory space or I/O space. The awi driver en- capsulates all IP and ARP traffic as 802.11 frames. Transmit speed is fixed at 1Mbps. The driver currently only works in infrastructure mode, communicating with an Access Point which serves as a link-layer bridge between an Eth- ernet and the wireless network. This card seems to take between 5 and 20 seconds after it has been brought up to synchronize with an AP. When using dhclient(8) to automati- cally configure an address on this card, it may be advisable to delay the invocation of dhclient for about 10 seconds after the card is brought up using ifconfig(8).
awi0: unable to allocate memory space; using i/o only Indicates that the driver was not able to allocate 32kb of PCMCIA bus address space into which to map the device; the driver will use the (slightly slower) i/o- space only access methods to read and write to the shared memory. This message is in some sense to be expected and should not be a cause for alarm. See pcmcia(4) for information on how to increase the memory avail- able to the PCMCIA controller. awi0: selftest failed (code %x) The device failed to pass its internal selftest. awi0: device failed to complete selftest (code %x) The device failed to complete its self test within 5 seconds. awi0: device timeout awi0: timeout waiting for command completion The device failed to gen- erate an interrupt to acknowledge a command. awi0: transmit timeout The device failed to generate an interrupt to acknowledge a transmitted packet. awi0: large frame truncated The system handed the driver a packet which was too large to transmit in one piece. awi0: device enable failed The system was unable to power on the card. awi0: associated with %s, SSID: %s The device has successfully synchron- ized with the identified Access Point and is ready to relay traffic. awi0: no recent beacon from %s; rescanning The device has not heard a beacon from its currently associated Access Point recently, and is look- ing for a new Access Point. awi0: received deauth The Access Point the card was most recently asso- ciated with has forgotten about us.
arp(4), ifmedia(4), intro(4), netintro(4), pcmcia(4), hostname.if(5), ifconfig(8) Am79C930 PCnet Mobile Single-Chip Wireless LAN Media Access Controller, http://www.amd.com.
The awi device driver first appeared in OpenBSD 2.7.
The awi driver was written by Bill Sommerfeld <firstname.lastname@example.org> and ported to OpenBSD by Angelos D. Keromytis <email@example.com>
Doesn't support ad-hoc mode or WEP. Round trip times seem higher than what one might expect. MirOS BSD #10-current March 20, 2004 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.