AUICH(4) BSD Programmer's Manual AUICH(4)
auich - Intel 82801AA/AB/BA/CA/DB/EB, 82440MX, and compatibles PCI audio driver
auich* at pci? dev ? function ? flags 0x0000 audio* at auich?
The auich driver provides support for the AC97-based audio present on the Intel 82801AA/AB/BA/CA/DB/EB I/O controller hub (ICH/ICH0/ICH2/ICH3/ICH4/ICH5), 82440MX chipset, SiS 7012, AMD 768, AMD 8111, NVIDIA nForce and nForce2 chips. The auich DMA engine supports full-duplex operation and has separate channels for line input and micro- phone. Unfortunately, simultaneous recording from both line and micro- phone inputs is not supported due to the current ac97(4) design. Setting flags to 0x0001 will compensate for machines that have reversed stereo.
ac97(4), audio(4), intro(4), pci(4)
The auich device driver appeared in OpenBSD 2.8.
Some hardware implementations only support 48kHz sampling rates. MirOS BSD #10-current May 30, 2000 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.