AST(4) BSD Programmer's Manual AST(4)
ast - multiplexing serial communications interface
ast0 at isa? port 0x1a0 irq 5 ast1 at isa? port 0x2a0 irq 6 com* at ast? slave ? or pccom* at ast? slave ?
The ast driver provides support for boards that multiplex together up to four EIA RS-232C (CCITT V.28) communications interfaces. Apparently the original master of hardware using this multiplexing protocol was AST. Each ast device is the master device for up to four com or pccom devices. The kernel configuration specifies these com devices as slave devices of the ast device, as shown in SYNOPSIS. The slave ID given for each com device determines which bit in the interrupt multiplexing register is tested to find interrupts for that device. The port specification for the ast device is used to compute the base addresses for the com subdevices and the port for the interrupt multiplexing register. On a real AST card, the jumpers are as follows: SW1-1 Turn ON for irq 2. Default is OFF. SW1-2 Turn ON for irq 3. Default is OFF. SW1-3 Turn ON for irq 4. Default is OFF. SW2-1 Turn ON for irq 5. This is ON for the first card, OFF otherwise. SW2-2 Turn ON for irq 6. This is ON for the second card, OFF otherwise. SW2-3 Turn ON for irq 7. Default is OFF. SW3-1 "Compatible mode". The ast driver needs extended mode, so leave this OFF. SW3-2 IO Address. In extended mode, this should be OFF for the first card at 0x1a0-0x1a7 and ON for the second card at 0x2a0-0x2a7. SW3-3 Interrupt sharing. Default is OFF. SW3-4 Reserved, must be OFF.
com(4), intro(4), isa(4)
The ast driver was written by Roland McGrath and placed into the public domain. MirOS BSD #10-current March 30, 1994 1
Generated on 2014-02-10 02:47:05 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.