ADVANSYS(4) BSD Programmer's Manual ADVANSYS(4)
advansys - AdvanSys PCI SCSI Host Adapters
adv* at pci? dev ? function ? scsibus* at adv? adw* at pci? dev ? function ? scsibus* at adw?
The advansys drivers support most AdvanSys PCI SCSI host adapters, as shown in this table: adv adw ABP-920 ABP-940UW ABP-930 (1) ABP-940UWD ABP-930U ABP-970UW ABP-930UA ASB-3940UW-00 ABP-940 ASB-3940U2W-00 ABP-940U ASB-3950U160 ABP-940UA ABP-950 ABP-960 (2) ABP-960U (2) ABP-970 ABP-970U ABP-980 ABP-980U 1. This board has been sold by SIIG as the Fast SCSI Pro PCI. 2. This board has been sold by Iomega as a Jaz Jet PCI adapter. The adw driver will log some host adapter errors with general messages such as adw0:0:0: host adapter error 0x12. See adw(4). adw0:0:0: host adapter error 0x12, resetting bus. See adw(4). Some further information on the meaning of such errors can be obtained from the following table derived from the source code provided by Con- nectCom. Error Define Name Comment 0x12 QHSTA_M_SXFR_XFR_OFLW SXFR_STATUS Transfer Overflow 0x13 QHSTA_M_UNEXPECTED_BUS_FREE 0x15 QHSTA_M_QUEUE_ABORTED 0x16 QHSTA_M_SXFR_SDMA_ERR SXFR_STATUS SCSI DMA Error 0x17 QHSTA_M_SXFR_SXFR_PERR SXFR_STATUS SCSI Bus Parity Error 0x18 QHSTA_M_RDMA_PERR RISC PCI DMA parity error 0x19 QHSTA_M_SXFR_OFF_UFLW SXFR_STATUS Offset Underflow 0x20 QHSTA_M_SXFR_OFF_OFLW SXFR_STATUS Offset Overflow 0x21 QHSTA_M_SXFR_WD_TMO SXFR_STATUS Watchdog Timeout 0x22 QHSTA_M_SXFR_DESELECTED SXFR_STATUS Deselected 0x24 QHSTA_M_SXFR_XFR_PH_ERR SXFR_STATUS Transfer Phase Error 0x25 QHSTA_M_SXFR_UNKNOWN_ERROR SXFR_STATUS Unknown Error 0x30 QHSTA_M_SCSI_BUS_RESET Request aborted from SBR 0x31 QHSTA_M_SCSI_BUS_RESET_UNSOL Request aborted from unsolicited SBR 0x32 QHSTA_M_BUS_DEVICE_RESET Request aborted from BDR 0x35 QHSTA_M_DIRECTION_ERR Data Phase mismatch 0x36 QHSTA_M_DIRECTION_ERR_HUNG Data Phase mismatch and bus hang 0x41 QHSTA_M_WTM_TIMEOUT 0x42 QHSTA_M_BAD_CMPL_STATUS_IN 0x43 QHSTA_M_NO_AUTO_REQ_SENSE 0x44 QHSTA_M_AUTO_REQ_SENSE_FAIL 0x45 QHSTA_M_INVALID_DEVICE Bad target ID 0x46 QHSTA_M_FROZEN_TIDQ TID Queue frozen 0x47 QHSTA_M_SGBACKUP_ERROR Scatter-Gather backup error
cd(4), ch(4), intro(4), scsi(4), sd(4), ss(4), st(4), uk(4) http://www.connectcom.net/
The advansys drivers were originally written by Baldassare Dante Profeta for NetBSD, based on Linux drivers written by Advanced System Products, Inc., which is now ConnectCom Solutions, Inc. MirOS BSD #10-current September 28, 1998 1
Generated on 2014-07-04 21:17:45 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.